Update can't really end

I am updating from 19 to 26. I’m doing so from one major version to the next. The last applied is 22.2.10.

My method is

  • Copying all files via FTP.
  • Opening NextCloud webpage.
  • Clicking on update/upgrade.

For this major update, it says it is ended, but when navigating back to NextCloud webpage, I am getting the same “have to update” message.

I tried to connect via SSH to execute "./occ upgrade" that ended successfully, but still the same page asking me to update.


I added debug info in OC_Util->needUpgrade and I can tell those applications return they need to be upgraded (as stated by the upgrade page).

  • Federated file sharing (federatedfilesharing)
  • Federation (federation)
  • File sharing (files_sharing)
  • Deleted files (files_trashbin)

I assume you’re upgrading PHP as you go along? That’s quite a jump in releases! The PHP versions required by those NC versions are all very different and also very important.

You may want to try a command line based run of the updater too: Upgrade via built-in updater — Nextcloud latest Administration Manual latest documentation

If still stuck, also provide the output of ./occ upgrade.

I am on a shared hosting, but I can adjust my PHP version. Which I am doing.

Before this morning, I never needed to connect via SSH and I discovered it was disabled. Connected, I can now try the command line version of the updater and not the web one. Because I tried using it, and it fails at creating a backup.

I am currently running it and it is upgrading to 23.0.12. Right now, still in the “create backup” step.

It failed at the same step: 3 - creating backup. (Running the command line upgrader)

./occ upgrade

The current PHP memory limit is below the recommended value of 512MB.
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
Setting log level to debug
Turned on maintenance mode
Updating database schema
Updated database
Updating <federation> ...
Updated <federation> to 1.12.0
Updating <files_sharing> ...
Updated <files_sharing> to 1.14.0
Updating <files_trashbin> ...
Updated <files_trashbin> to 1.12.0
Updating <federatedfilesharing> ...
Updated <federatedfilesharing> to 1.12.0
Starting code integrity check...
Finished code integrity check
Update successful
Turned off maintenance mode
Resetting log level

@jtr Using the command line updater, I got missing memory in error_log file. I changed my PHP settings to have 512MB per script. It passed. Now I am at 23.X.X.X. Next!

Thank you!

1 Like