Update, bug. Files Web App not displaying folder description after NC 28 when navigating from Favorites

After NC 28 the files app does not display file info despite it being set to show it in settings. I’ve tried multiple modern browsers including Firefox, Safari, Edge, etc and same, no file info. Is anyone else experiencing this?

Also, where can I file an official detailed bug report for this so it gets the proper attention of the dev team?

Thanks

Can you provide a screenshot? I’m not clear about what you’re not seeing.

Screenshot 2024-01-12 123317

With Show folder description checked it should display the contents of the readme.md file above the files. As you can see, it only displays the readme.md file and not it’s contents. To view the contents of the readme.md file I have to click on it. This should be unnecessary if Show folder description is checked, the contents of the readme.md should display in a scrollable viewport above the files.

Hi there, I understand folks are busy, but would appreciate if this bug got some love and attention. A response would be greatly appreciated. Thank you.

Hi @flotillaropes, it seems to be a bug … it works for me

Unsure what you mean. You say it seems to be a bug, but it works for you? Are you on 27 and it works for you?

It does work on my 28.0.1 test instance, so I’m not sure why it doesn’t work for you. Maybe some app you have installed is causing it…?

I’m only using a few nextcloud official apps. Unsure why this would cause it to not work. It always worked before 28, same apps.

Curious, what browser are you using? I’m using Firefox v122 64bit on Win10

Same here.

No, I tested it on NC 28.0.1 and it was working for me.

It is actually not that uncommon for apps to cause side effects, so it can definitely make sense to disable the apps one by one in order to see if an issue disappears after disabling a certain app.

However, I don’t have a definitive answer as to what is causing your issue, which is why I wrote: “I’m not sure why it doesn’t work for you. Maybe some app you have installed is causing it…?” …with a question mark at the end. :wink:

Ok, tested other account and works fine. So question is why has it stopped working for my account, but works fine for a test account on same server?

I also rebuilt a fresh install of nextcloud. Tested with new install and works. However, I restored my data and now it’s broken for my account. Any ideas why this is happening? Why should it matter which account I use to login and use nextcloud? Why should that break a key feature?

Hi @flotillaropes, do you have any logs related to your issue?

The logs are clean

Hi @flotillaropes, Did your issue occur in all of your folders?
a new update of NC 28 has been released since yesterday, have you upgraded?

I’m glad you asked as the issue occurs with virtually all folders. However, occasionally it works on a random folder. I did update to 28.02 hoping the issue would be resolved, but sadly it remains.

@flotillaropes I don’t know how to help you… there is nothing about your issue (no logs).
Have you tried this command? occ maintenance:repair
I don’t think it will solve your problem, but it’s worth a try.

This command has to be executed by lunix owner of nextcloud server folder and from inside this folder.
you can also use this command :
sudo -u user php8.0 /.../nextcloud/occ maintenance:repair

Replace

  • user by yours (example: www-data)
  • php8.0 by your version of PHP (example : php8.2)
  • and /…/ by your path of nextcloud server folder

Yes, but didn’t solve the issue. Interestingly on mobile apps, the folder info does display on top. It’s the browser files app that has the issue.

Hoping someone else can chime in from nextcloud team. I’ve been a nextcloud user since version 10 so a long time and know nextcloud pretty well. I never had this issue until the update to 28. I understand the files app was rewritten for 28. Something broke with folder info and it very well may be obscure. I hope someone from the nextcloud team will jump in and join the effort to get this resolved. Where can I file an official bug report on gibhub?

What about your browser console logs?