Update auf 24 bleibt stehen

Hallo, evtl. kann mir jemand helfen. Wollte gerade ein update der nextcloud machen, jedoch bekomme ich kurz vor dem Ende folgendes, was ist hier zu tun?:

Grafik lässt sich nicht hochladen!!!

grafik

oje es wird schlimmer, im Browser nur noch eine 403 Meldung. In der ssh Konsole: Step end is currently in process. Please call this command later.

Habe die .step Datei umbenannt und php updater.phar abgesendet nun erhalte ich:
Extracting …PHP Warning: require(/www/htdocs/nextcloud/updater/…/version.php): failed to open stream: No such file or directory in phar:///www/htdocs/nextcloud/updater/updater.phar/lib/Updater.php on line 658
PHP Warning: require(/www/htdocs/nextcloud/updater/…/version.php): failed to open stream: No such file or directory in phar:///www/htdocs/nextcloud/updater/updater.phar/lib/Updater.php on line 658
PHP Fatal error: require(): Failed opening required ‘/www/htdocs/nextcloud/updater/…/version.php’ (include_path=’.:/usr/share/php:…’) in phar:///www/htdocs/nextcloud/updater/updater.phar/lib/Updater.php on line 658

in step 4 wurde ein Backup angelegt (oder du hast zuvor selbst eins gezogen), spiel das bitte wieder ein und dann versuch es nochmal.

@JimmyKater
Nun habe ich mal eine Frage zu der Fehlermeldung. Ist es vielleicht so, dass beim Update von der alten Installation “version.php” gelöscht wird und nach dem Entpacken der neuen Version die Datei “version.php” nicht da ist, da z. B. die neue Version gar nicht gezogen und/oder entpackt wurde? Würde mich mal interessieren, da das die Fehlermeldung ja irgendwie aussagt.

updater.phar findet irgendwie …/version.php nicht

thx, im Moment kopiere ich gerade nochmals den alten Stand (vor dem update auf 24…) auf den Webserver, das dauert jetzt bestimmt schon gefühlt 24h. Ich würde mich zu diesem Thema nochmals melden, wenn ich wieder so weit bin und vor dem update stehe…

@devnull das könnte natürlich immer möglich sein… aber das müsste dann ja ein Problem für alle sein, oder nicht? Und bisher sehr ich hier keine Hinweise drauf, dass das ein Majorbug ist.

ich könnte mir vorstellen, dass das downloadfile ggf beschädigt war oder dass irgendwelche Permissions nicht stimmen oder oder oder

1 Like

thx, ich bin soweit alles kopiert und nextcloud läuft, allerdings ist es jetzt nicht das 24.x Update was ich angeboten bekommen, sondern siehe Bild. Ebenfalls habe ich ganz oben eine Integritäts- Meldung, die ich erst einmal bearbeiten muss, aber…

Bild hochladen geht mal wieder nicht, versuche es nach zu liefern…

Bild geht immer noch nicht, also dann schriftlich: Die Update Version ist jetzt 23.0.5.
Die Nummern im Array habe ich durch … gekürzt:

Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results

  • core
    • INVALID_HASH
      • .user.ini
      • core/js/mimetypelist.js
    • EXTRA_FILE
      • ocs/error_log

Raw output

Array
(
[core] => Array
(
[INVALID_HASH] => Array
(
[.user.ini] => Array
(
[expected] => 484…
[current] => 752…
)

                [core/js/mimetypelist.js] => Array
                    (
                        [expected] => 941...
                        [current] => 1b0....
                    )

            )

        [EXTRA_FILE] => Array
            (
                [ocs/error_log] => Array
                    (
                        [expected] => 
                        [current] => ece...
                    )

            )

    )

)

i.d.r sind die invalid hashes durch die Originalfiles aus dem Update-Zip-file zu ersetzen (der Version, die aktuell auf deinem Server installiert ist)
Das extra-File kannst du m.E. einfach löschen…

ok, danke habe das ‘EXTRA_FILE’ gelöscht. wie sieht es mit den ‘INVALID_HASH’ aus auch löschen oder? Falls von Interessen mein Webhoster ist all-inkl.com

nein, die invalid hashes durch die Originalversionen aus dem entsprechenden Update-zip-file extrahieren und an den erforderlichen Orten einfügen. Also die fehlerhaften Dateien (aus irgendeinem Grund sind die nicht die originalen) mit den entzippten ersetzen.

Ok thx, werde ich tun, jedoch hat z.B. die user.ini bei mir Einträge (Memory_Limit).