Update 19.0.1 -> 19.0.2


I’m running NC 19.0.1 on CentOS 8 with apache as webserver.
When using the updater to update to 19.0.2, I get the next error :slight_smile:

Check for write permissions

The following places can not be written to:

  • /var/www/html/nextcloud/updater/…/AUTHORS
  • /var/www/html/nextcloud/updater/…/index.php
  • /var/www/html/nextcloud/updater/…/status.php
  • /var/www/html/nextcloud/updater/…/robots.txt
  • /var/www/html/nextcloud/updater/…/occ
  • /var/www/html/nextcloud/updater/…/remote.php
  • /var/www/html/nextcloud/updater/…/console.php
  • /var/www/html/nextcloud/updater/…/version.php
  • /var/www/html/nextcloud/updater/…/cron.php
  • /var/www/html/nextcloud/updater/…/index.html
  • /var/www/html/nextcloud/updater/…/public.php
  • /var/www/html/nextcloud/updater/…/COPYING

I already checked some files, and user apache (which runs httpd) can write to the files. Also searched and there are no files owned by root under /var/www/html/nextcloud/.

Any idea what could be the problem ?

Best regards,

No real idea. Perhaps no space on partition? You can delete old backups in /var/www/html/nextcloud/data/updater-…/backups

New setup, plenty of space left on al partitions …

1 Like

I disabled SELinux and the updater did his work. The SELinux configuration was done as explained in : https://docs.nextcloud.com/server/19/admin_manual/installation/example_centos.html

Did the test again on a VBox, but with the following additional commands executed

semanage fcontext -a -t httpd_sys_rw_content_t ‘/var/www/html(/.*)?’
restorecon -R ‘/var/www/html/’

Started the updater again with SELinux enabled (enforcing) and the update passed without issues.


Good evening everyone,
sorry if I enter, but I too have an update problem. I tried to upgrade my server with Ubuntu 18.04 server, Apache, mariadb, PHP 7.4, but it gives me this error message:
Doctrine \ DBAL \ Exception \ DriverException: An exception occurred while executing ‘ALTER TABLE oc_addressbooks CONVERT TO CHARACTER SET utf8mb4 COLLATE utf8mb4_bin;’: SQLSTATE [42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 767 bytes

What can I do?
Thank you all! :slight_smile:

When I try to update, I have this error:

  • Check for expected files

The following extra files have been found:

  • search

What is “search”?

Please open in future an own thread. I think in your nextcloud directory /var/www/html/nextcloud (???) is a file or folder named “search”. Delete it or move it outside your nextcloud directory. Look in the file or directory. Perhaps you need the data. Nextcloud does not need them.

What is the characterset of you database ?

Hi, I tried to update two nextcloud docker containers today using the “apply update” in button in unraid docker manager. The docker containers deleted hundreds of gigs of data from bind mount hard drives and will no longer start. The persistent container data has been reset to new sample data from the image. This is not the first time this has done this and i have had to restore from backups but each time i loose a small hand full of files. Anyone please tell me why in the h*** this is happening? I have no backups for my instances. so there goes all that work again.

I delete the directory “search” and now it works.
Thank you

I resolved the issue in the short term by removing bind mounts to the container and letting it update then adding the bind mounts again. Still does not solve my issue with this in the future and my data loss in the bind mounted drives.