Update 13.0.2 > 13.0.4 via updater fails / Webhoster

Hi there,

Yesterday I tried to update my production instance and it failed. Everything seemed to be ok until I clicked “Return to main site to complete your update”. After I clicked I was redirected to my main site but it only showed up “Update in process” (white background and just black characters) and nothing happended. I reloaded the browser tab nothing changed the current status. I tried to disable the maintenance mode, no change. I tried to login to the updater.php directly but the login failed because of the wrong password. But I tried it with the correct one. The only solution was to rollback to 13.0.2 by manually copying the backup files and folders.

However, today I tried the update with my testing environment. I updated from 11.0.2 to 12.0.9 and from 12.0.9. to 13.0.4 and the update failed again. This time the redirecting from the updater site to my main site to complete the updating process led me to blank page. Currenty I am trying to rollback to 12.0.9.

Are there any bugs in the updating process? Does anyone get the same errors like me?

Quick update: after restoring my backup my testing instance is back online.

@campfire please, solve tick box.

Hi @stratege1401

I am sorry I don’t get the point. What tick box do you mean?

the green one


Ah I get the point. I did not want to say that the problem in itself has been solved. I only did a rollback to version 13.0.2.

Ok guys, I found a solution provided here (German only): https://forum.kuketz-blog.de/viewtopic.php?f=48&t=3392&sid=2a0e3642e734d945204d3e0dd08f35dc#p33596

I needed a manual upgrade: https://docs.nextcloud.com/server/15/admin_manual/maintenance/manual_upgrade.html. I noted my 3rd party apps in the first place and made a full backup of my installation.

Follow the steps in the upgrade manual but ignore steps 3, 10 and 11. In my case I do not have a full root access on my server. After finishing the preparation I needed to execute this command

php occ upgrade

Unfortunately I ran into problems with PHP. So I reloaded my Nextcloud installation and did the upgrade via the web gui. And voilá it worked like a charm!