Updata on 28.0.0. beta 3 failed

Hi all together,

my update to 28.0.0. beta 3 I get the following error message: "Exception: Database error when running migration 28000Date20230906104802 for app core Index name “sa” for table “oc_social_3_stream_act” collides with the constraint on table “oc_social_stream_act”
Update was running succesfully from the commandline, and when I was accessing the Nextcloud via Web, ist was showing me, the screen, that I can now start the update. When I did, I see the above error messang, when i do now upgrade from commandline, I get the same. Any ideas, what I can do, to fix it?

Greetings,

Sven

Did you follow these steps:

mentioned here here in the official announcement (which one should ALWAYS visit before updating a beta product!): Third beta of Nextcloud 28

Much luck,
ernolf

Thank you very much. I did not read the release notes. Now I did like mentioned there, with still the same result:
“Exception: Database error when running migration 28000Date20230906104802 for app core
Index name “sa” for table “oc_social_3_stream_act” collides with the constraint on table “oc_social_stream_act”.
Update failed”

I had the same problem when upgrading from 28.0.6 to NC 29.0.1.

solved it in my docker container by directly deleting the obsolete database files with

 MYSQL_ROOT_PASSWORD=****; docker exec nextcloud_db_1 sh -c 'mv -v /var/lib/mysql/nextcloud/oc_social_3* /var/tmp/'
1 Like