Unknown error when uploading certain files from web ui and cant sync from android

Support intro

Hi. I am new to nextcloud. I am having a problem uploading files. When I upload files from the web gui the file upload to 100% then I receive the following error “An unknown error has occurred”. If I change the file extension to .php the file uploads fine.
From the android app, I can download files perfectly well, but when I try to upload I receive an error “Method not found”
I had received an error using other sync apps which support nextcloud as well.
Please assist me. :blush:

Server configuration detail

Operating system: Linux 3.10.0-962.3.2.lve1.5.26.7.el7.x86_64 #1 SMP Wed Oct 2 07:53:12 EDT 2019 x86_64

Webserver: LiteSpeed (litespeed)

Database: mysql 5.7.32

PHP version: 7.2.34

Modules loaded: Core, date, libxml, openssl, pcre, sqlite3, zlib, bz2, calendar, ctype, curl, hash, filter, ftp, gettext, gmp, SPL, iconv, pcntl, readline, Reflection, session, standard, shmop, SimpleXML, mbstring, tokenizer, xml, litespeed, bcmath, dba, dom, enchant, fileinfo, gd, imap, intl, json, ldap, exif, mysqlnd, mysqli, odbc, PDO, pdo_mysql, PDO_ODBC, pdo_pgsql, pdo_sqlite, pgsql, Phar, posix, pspell, snmp, soap, sockets, sysvmsg, sysvsem, sysvshm, tidy, wddx, xmlreader, xmlrpc, xmlwriter, xsl, zip, ionCube Loader

Nextcloud version: 20.0.4 -

Updated from an older Nextcloud/ownCloud or fresh install:

Where did you install Nextcloud from: unknown

Signing status

Array ( )

List of activated apps
 - accessibility: 1.6.0
 - activity: 2.13.4
 - admin_audit: 1.10.0
 - bruteforcesettings: 2.0.1
 - calendar: 2.1.2
 - cloud_federation_api: 1.3.0
 - comments: 1.10.0
 - contacts: 3.4.2
 - contactsinteraction: 1.1.0
 - dashboard: 7.0.0
 - dav: 1.16.2
 - federatedfilesharing: 1.10.2
 - federation: 1.10.1
 - files: 1.15.0
 - files_external: 1.11.1
 - files_pdfviewer: 2.0.1
 - files_rightclick: 0.17.0
 - files_sharing: 1.12.1
 - files_trashbin: 1.10.1
 - files_versions: 1.13.0
 - files_videoplayer: 1.9.0
 - firstrunwizard: 2.9.0
 - flowupload: 1.1.2
 - logreader: 2.5.0
 - lookup_server_connector: 1.8.0
 - nextcloud_announcements: 1.9.0
 - notifications: 2.8.0
 - oauth2: 1.8.0
 - password_policy: 1.10.1
 - photos: 1.2.1
 - privacy: 1.4.0
 - provisioning_api: 1.10.0
 - recommendations: 0.8.0
 - richdocuments: 3.7.11
 - serverinfo: 1.10.0
 - settings: 1.2.0
 - sharebymail: 1.10.0
 - spreed: 10.0.4
 - support: 1.3.0
 - survey_client: 1.8.0
 - systemtags: 1.10.0
 - text: 3.1.0
 - theming: 1.11.0
 - twofactor_backupcodes: 1.9.0
 - updatenotification: 1.10.0
 - user_status: 1.0.1
 - video_converter: 0.1.5
 - viewer: 1.4.0
 - weather_status: 1.0.0
 - workflowengine: 2.2.0
 - encryption
 - files_accesscontrol
 - user_ldap

Configuration (config/config.php)
    "instanceid": "***REMOVED SENSITIVE VALUE***",
    "passwordsalt": "***REMOVED SENSITIVE VALUE***",
    "secret": "***REMOVED SENSITIVE VALUE***",
    "trusted_domains": [
    "datadirectory": "***REMOVED SENSITIVE VALUE***",
    "dbtype": "mysql",
    "version": "",
    "overwrite.cli.url": "https:\/\/nextcloud.yahya.nom.za\/nextcloud",
    "dbname": "***REMOVED SENSITIVE VALUE***",
    "dbhost": "***REMOVED SENSITIVE VALUE***",
    "dbport": "",
    "dbtableprefix": "oc_",
    "mysql.utf8mb4": true,
    "dbuser": "***REMOVED SENSITIVE VALUE***",
    "dbpassword": "***REMOVED SENSITIVE VALUE***",
    "installed": true,
    "loglevel": 0

External storages: yes

External storage configuration
No mounts configured

Encryption: no


  • OC\User\Database

Browser: Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.105 Safari/537.36

Hi Yahya_B

cloud you solve the problem?


No. I decided to use a program called pydio. Although it has less features, it can upload fine. It is possible that nextcloud uses the put protocol which is usually blocked in cpanel.

OK sorry to hear that it wasn’t working for you.
If you like to give it a try again here the solution that worked for me.


Hi hezel,

I’m not sure if you put the right link into the mail. If I click on it I came to my own post :wink:.



Hi Spinneroo,

thanks for the hint, the issues i had could be fix with the update in php.ini to the correct path of the tmp folder.
Therefor I linked your Post because post from @FadeFx solved my issue.

Hi. I had fixed the problem by adding the following to .htaccess:

<IfModule mod_security.c>
  SecFilterEngine Off
  SecFilterScanPOST Off