"Unknown Error" when auto-uploading photos and videos

Hi,

I’m using the latest version of nextcloud (10.0.1) and version 1.3.1 of the Android (6.0.1) app, and uploading photos and videos automatically seems to be very hit and miss, and once failed they will always fail. This is over wifi/charging/3g/not charging, it makes no difference. Uploading the photos from the web client on the phone, or through the windows client works fine.

The problem shows up as the photo appears to start uploading, but gets stuck at a random %, usually somewhere between 60% and 80%, then will fail with a message about “the server…” in the notification (I can’t seem to read the rest), but then when I go into the app it just says “Unknown error”.
I’ve been trying to find the logs from the app, but can’t seem to find the button someone referred to in settings. I’ve tried signing up for the beta version of the app, as well as clearing the cache, uninstalling/reinstalling, but nothing seems to have worked.

The only error I can find is in nextcloud and says…
“Exception: {“Message”:“HTTP/1.1 409 Parent node does not exist”,“Exception”:“Sabre\DAV\Exception\Conflict”,“Code”:0,“Trace”:”#0 /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php(588): Sabre\DAV\Server->createCollection(‘Peter/Pictures/…’, Object(Sabre\DAV\MkCol))\n#1 [internal function]: Sabre\DAV\CorePlugin->httpMkcol(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#2 /var/www/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#3 /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php(459): Sabre\Event\EventEmitter->emit(‘method:MKCOL’, Array)\n#4 /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php(248): Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#5 /var/www/nextcloud/apps/dav/appinfo/v1/webdav.php(60): Sabre\DAV\Server->exec()\n#6 /var/www/nextcloud/remote.php(165): require_once(’/var/www/nextcl…’)\n#7 {main}",“File”:"/var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php",“Line”:1107,“User”:“peter”}"

The timing doesn’t seem to always match up though.

My wife also has the same problem, which makes me think it’s something wrong with the server or the app, but the server isn’t throwing errors.

I’m a bit stuck, has anyone seen this behavior before/point me in the direction of how to work out what’s wrong?

Thank you!

Peter

This might be related to chunking: https://github.com/nextcloud/android/issues/329
A fix has already been provided by a community member that needs to be tested first, than if it works it will be put into the beta app, then the at that moment upcoming stable/RC.

Thank you for your reply, I searched and read quite a few posts, but my terms didn’t pick up that report. It does sound very similar so I’ll wait and see if it fixes it.
For what its worth I suspected it was if the file failed to upload the first time, so tried setting it to WiFi only, plugging it in, taking a photo and watching it upload (ie screen on to prevent any sort of connection drop), but it still failed. I also tried clearing out the chunking data left in the file cache on the server (likely not best practice I know) but that didn’t help either.

1 Like

@lilpete IN around 24H

IF you have some time to spare you can download and install/test the
(upcoming) beta app (like before it can be installed in parallel to the
stable release) https://f-droid.org/repository/browse/?fdfilter=Nextcloud&fdid=com.nextcloud.android.beta

The next beta release has a fix for chunking. As for bugs if they occur please report them on our issue tracker https://github.com/nextcloud/android/issues Thanks for your patience and any help testing.

Beta version 20161026 is live! :sun_with_face:

1 Like

Hi Andy,

Thanks for letting me know, I’ve had a look and the instant upload doesn’t seem to be being triggered when I take a photo, the issue has already been recorded here (https://github.com/nextcloud/android/issues/363) by someone else. The log files are completely blank too, so sadly of no help!

Also I now have this issue too (https://github.com/nextcloud/android/issues/341) but I understand that’s server-side and should be fixed in the next update.

Peter

Hi @lilpete,

Exactly yes, should be fixed with 10.x.
As for the other issue, are your photos stored on internal memory or a SD card?

Andy

Hi Andy,
My pictures are stored on internal memory. If it makes any difference my phone is the OnePlus 3 and has no SD card.
Peter

Dear All,

I am running NextCloud version 11.0.0, upgraded from 10.0.0 manually. Two users are active each having a android phone & tablet and a windows computer with CardBook on Thunderbird.

I noticed that synchronization stopped only for one user, there were no new entries in the session log for that user. I have the following fatal error in the administrators log after a more than 8 days running perfectly:
Sabre\DAV\Exception\Conflict: HTTP/1.1 409 Parent node does not exist - 2017-01-02T16:51:46+0100.

I have noticed that synchronizing my phone and tablet seems to work after some manual start on phone and tablet, but in the session log shows no new entries for the last three days. The other user on the same server works fine synchronizing every half hour with phone and tablet.

I see no solution, I have tried rebooting the server but that does not change anything.

May there is an solution? Thank you for any help! Regards, Cees.