Undefined offset: 2 at /var/www/html/nextcloud/apps/onlyoffice/controller/editorcontroller.php#434

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2):
Nextcloud = 14.0.6
Operating system and version (eg, Ubuntu 17.04) :
OS = Debian 9
Apache or nginx version (eg, Apache 2.4.25) :
Apache 2
PHP version (eg, 7.1) :
PHP 70

The issue you are facing:
Undefined offset: 2 at /var/www/html/nextcloud/apps/onlyoffice/controller/editorcontroller.php#434

i use certbot, onlyoffice in docker. everithing works fine. but i get these errors. fail2ban ban’s me sometimes.
i use the cert in debian and in docker.
no errors if i go to https://MYSITE.dnshome.de:4433/welcome/
no errors if i go to https://MYSITE.dnshome.de
certs are accepted on both destinations.

Is this the first time you’ve seen this error? (Y/N):
yes
i updated yesterday onlyofficedocker + nextcloud
system is up to date

Steps to replicate it:

  1. edit onlyoffice document

The output of your Nextcloud log in Admin > Logging:

Undefined offset: 2 at /var/www/html/nextcloud/apps/onlyoffice/controller/editorcontroller.php#434


The output of your config.php file in `/path/to/nextcloud` (make sure you remove any identifiable information!):

sudo -u www-data php ./occ config:list system
{
“system”: {
“instanceid”: “REMOVED SENSITIVE VALUE”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
“192.168.24.100”,
“server1”,
REMOVED.dnshome.de
],
“datadirectory”: “REMOVED SENSITIVE VALUE”,
“dbtype”: “mysql”,
“version”: “14.0.6.0”,
“overwrite.cli.url”: “https://192.168.24.100”,
“dbname”: “REMOVED SENSITIVE VALUE”,
“dbhost”: “REMOVED SENSITIVE VALUE”,
“dbport”: “”,
“dbtableprefix”: “oc_”,
“dbuser”: “REMOVED SENSITIVE VALUE”,
“dbpassword”: “REMOVED SENSITIVE VALUE”,
“installed”: true,
“csrf.disabled”: false,
“memcached_servers”: [
[
“127.0.0.1”,
11211
]
],
“memcache.local”: “\OC\Memcache\APCu”,
“mail_smtpmode”: “sendmail”,
“mail_from_address”: “REMOVED SENSITIVE VALUE”,
“mail_domain”: “REMOVED SENSITIVE VALUE”,
“maintenance”: false,
“theme”: “”,
“loglevel”: 2,
“mail_smtpauthtype”: “LOGIN”,
“mail_smtpauth”: 1,
“mail_smtphost”: “REMOVED SENSITIVE VALUE”,
“mail_smtpport”: “25”,
“mail_smtpname”: “REMOVED SENSITIVE VALUE”,
“mail_smtppassword”: “REMOVED SENSITIVE VALUE”,
“mail_smtpsecure”: “tls”,
“0”: “app.mail.smtp.timeout 30”,
“onlyoffice”: {
“verify_peer_off”: true
},
“updater.secret”: “REMOVED SENSITIVE VALUE
}
}

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE