Unable to view active users

Updated to 24.0.7 (from 24.0.6) and the page active users page throws an error. I get a 404 on https://MY_DOMAIN/ocs/v2.php/cloud/users/details?offset=0&limit=25&search=

I can still create users and viewing users in groups works fine.

Any ideas ?

After digging a little bet my users coming from a specific AD are gone… I deactivated the AD app and reactivated it still no luck.

I have two AD setup and connection to AD #2 is fine but not to AD #1. I ended up copying the server using AD #1 in the AD app and it works now…

After more testing it appear that in the AD app does not work. Users are appearing and disappearing randomly and unable to login with the following in the logs :smiley:

user_ldap LDAP Login: Could not get user object for DN cn=PRIVATE,cn=PRIVATEdc=PRIVATE,dc=PRIVATE. Maybe the LDAP entry has no set display name attribute?

Weird and quite scary bug !

I ended up downloading the user_ldap folder from the backup created before the update. I disable the AD app then removed the folder in place and uploaded the backup + chmod.

Seems to be working so far…