Unable to upgrade using web updater

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2):
Operating system and version (eg, Ubuntu 17.04): Ubuntu 18.04
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.29
PHP version (eg, 7.1): 7.2.13 (I did try reverting to 7.1 but that did not help)

The issue you are facing:
the web updater no longer appears inside nextcloud. I used it to upgrade to 13.0.6 but it is not showing in the admin. I do get notices in my nextcloud client that new versions are available(currently 14.0.4

Is this the first time you’ve seen this error? (Y/N):Y

Steps to replicate it:

  1. log into nextcloud and go to settings, basic settings

The output of your Nextcloud log in Admin > Logging:

Only one error entry in the log from the past month. I did redact my domain name in the log. 

{"reqId":"QA7PCymOd5DyIIdWKtuc","level":4,"time":"2018-12-31T11:22:06+00:00","remoteAddr":"IP","user":"deb","app":"webdav","method":"MKCOL","url":"\/remote.php\/dav\/files\/deb\/Desktop\/%20%20%20%20%20%20%20%20%20%20%20","message":"Exception: {\"Exception\":\"OCA\\\\DAV\\\\Connector\\\\Sabre\\\\Exception\\\\InvalidPath\",\"Message\":\"Empty filename is not allowed\",\"Code\":0,\"Trace\":\"#0 \\\/var\\\/www\\\/vhosts\\\/domain.com\\\/cloud.domain.com\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(1178): OCA\\\\DAV\\\\Connector\\\\Sabre\\\\Directory->getChild('           ')\\n#1 \\\/var\\\/www\\\/vhosts\\\/domain.com\\\/cloud.domain.com\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/CorePlugin.php(594): Sabre\\\\DAV\\\\Server->createCollection('files\\\/deb\\\/Deskt...', Object(Sabre\\\\DAV\\\\MkCol))\\n#2 [internal function]: Sabre\\\\DAV\\\\CorePlugin->httpMkcol(Object(Sabre\\\\HTTP\\\\Request), Object(Sabre\\\\HTTP\\\\Response))\\n#3 \\\/var\\\/www\\\/vhosts\\\/domain.com\\\/cloud.domain.com\\\/3rdparty\\\/sabre\\\/event\\\/lib\\\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\\n#4 \\\/var\\\/www\\\/vhosts\\\/domain.com\\\/cloud.domain.com\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(479): Sabre\\\\Event\\\\EventEmitter->emit('method:MKCOL', Array)\\n#5 \\\/var\\\/www\\\/vhosts\\\/domain.com\\\/cloud.domain.com\\\/3rdparty\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(254): Sabre\\\\DAV\\\\Server->invokeMethod(Object(Sabre\\\\HTTP\\\\Request), Object(Sabre\\\\HTTP\\\\Response))\\n#6 \\\/var\\\/www\\\/vhosts\\\/domain.com\\\/cloud.domain.com\\\/apps\\\/dav\\\/lib\\\/Server.php(293): Sabre\\\\DAV\\\\Server->exec()\\n#7 \\\/var\\\/www\\\/vhosts\\\/domain.com\\\/cloud.domain.com\\\/apps\\\/dav\\\/appinfo\\\/v2\\\/remote.php(35): OCA\\\\DAV\\\\Server->exec()\\n#8 \\\/var\\\/www\\\/vhosts\\\/domain.com\\\/cloud.domain.com\\\/remote.php(164): require_once('\\\/var\\\/www\\\/vhosts...')\\n#9 {main}\",\"File\":\"\\\/var\\\/www\\\/vhosts\\\/domain.com\\\/cloud.domain.com\\\/apps\\\/dav\\\/lib\\\/Connector\\\/Sabre\\\/Directory.php\",\"Line\":227}","userAgent":"Mozilla\/5.0 (Linux) mirall\/2.3.3 (Nextcloud)","version":""}

The output of your config.php file in `/path/to/nextcloud` (make sure you remove any identifiable information!):
<?php $CONFIG = array ( 'instanceid' => 'redacted', 'passwordsalt' => 'redacted', 'secret' => 'redacted', 'trusted_domains' => array ( 0 => 'cloud.redacted.com', ), 'datadirectory' => '/var/www/vhosts/redacted.com/cloud.redacted.com/data', 'overwrite.cli.url' => 'https://cloud.redacted.com', 'dbtype' => 'mysql', 'version' => '', 'dbname' => 'redacted', 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'oc_', 'mysql.utf8mb4' => true, 'dbuser' => 'redacted', 'dbpassword' => 'redacted', 'installed' => true, 'maintenance' => false, 'theme' => '', 'loglevel' => 2, 'mail_from_address' => 'noreply', 'mail_smtpmode' => 'php', 'mail_smtpauthtype' => 'LOGIN', 'mail_domain' => 'cloud.redacted.com', 'data-fingerprint' => 'redacted', );``` The output of your Apache/nginx/system log in `/var/log/____`: ``` Only error from today is a few repeats of this 2019-01-07 12:07:48 Error IP [core:crit] (13)Permission denied: AH00529: /var/www/vhosts/redacted.com/cloud.redacted.com/data/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that '/var/www/vhosts/redacted.com/cloud.redacted.com/data/' is executable ```

I took a screenshot of where the updater is normally located. I also tried disabling all plugins but that did not help either.

This might be related to an APP interfering.

Deseable all APP ( at once or one by one ) and retry

I already did try that but I went ahead and tried disabling all the apps, logged out, cleared cache, and tried it again but it still is not showing up.

If your nextcloud is not a production server, you might try to do a manual update from 13 to 14.
And then from 14 to 15.

Otherwise, this might be a real bug, in that case open a ticket on the githuh repo for nextcloud server.