Unable to upgrade from ownCloud 10.0.1 to Nextcloud 12.0.0


It is stated here that

ownCloud 10.0.x is compatible with Nextcloud 12.0.x

However, when I run sudo -u www-data php /var/www/nextcloud/occ upgrade, I get a message saying that

Updates between multiple major versions and downgrades are unsupported

Here is the full output:

$ sudo -u www-data php /var/www/nextcloud/occ upgrade
Nextcloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
Set log level to debug
Exception: Updates between multiple major versions and downgrades are unsupported.
Update failed
Maintenance mode is kept active
Reset log level

I was following the manual upgrade guide.

Help is appreciated. Thanks.

i guess you should update to 11.0.3 first … simply move or copy the ./data and ./config/config.php out of your nextcloud folder and then remove that folder.

wget your tar.bz, unpack, move or copy your data and config into that new folder, chown it, start upgrade.

1 Like

Can I upgrade my installation using an updater script from this blog post? Or does it apply only to Nextcloud installations?

OK, found this blog post, where they are saying that upgrade from OC 10.0.1 to NC 12 is not yet possible. I would appreciate if that was mentioned on the main page for migrating to NC, to avoid this sort of confusion. Sorry, I must have missed it. Or it was updated after my initial message. :slight_smile:
I think I’ll just wait until they find a solution.

dude, read my post above, this solves it :wink:

I know, I saw your message, I’d just prefer to wait for a solution with direct upgrade. I’m not in a hurry :relieved:

allright… but … i dont think there is a solution for direct upgrading - well, actually im pretty sure that it wont exist. :smile:


Unless you’re directly involved in development you probably shouldn’t be saying that.

Once they’ve adequately tested it, a direct upgrade from OC to NC literally involves only downloading an index.php file to put in place of the ownCloud index.php. It’s pretty seamless.


oh, wow, i completely missed that then :hushed:


1 Like

Just hang tight, it won’t be long before they make an announcement :thumbsup:

Nextcloud have already a migration script for owncloud 10.0.1 but they didn’t released yet because this script is in testing phase.

It’s just some days to wait.

A post was split to a new topic: Updates between multiple major versions and downgrades are unsupported

Looks like it’s rather some months to wait.

So I have a question. Is it possible to upgrade to Nextcloud by doing a fresh installation of Nextcloud and pointing it to the existing ownCloud data directory? Will fresh installation of Nextcloud be populated with existing files then if I just recreate same users? It’s OK if I lose all settings, calendars, shares, etc, I only want files to be preserved.

yes, should be at least.

I’ve recovered plenty NC-instances from backups so far, and can say that I had a 100% success rate so far.

What you need is:

  • mysqldump of your database
  • [NCROOT]/data folder (complete)
  • config.php
  • the *.tar-file of that version you want to go back for
  • optional: all non core app-folders you may have activated

Steps are:

  • put NC in maintenance-mode if possible, or/and stop any further syncronization-traffic
  • wait a bit for connections to be closed
  • stop apache-service
  • dump your mysql-database
  • place your dump, data-folder, config.php, *.tar and app-folders somewhere outside of that NCROOT
  • remove your NCROOT-folder
  • unzip your *.tar
  • move/copy your data to the new NCROOT/data
  • move/copy your config.php into NCROOT/config/
  • chown -R www-data:www-data

and then go through the steps necessary to upgrade inbetween-major-versions.

should work.

Yes. Just did a fresh install of NC 12.0.1 on a clean database and a data directory left from OC. Worked almost fine. “Almost” because initial login took too long and resulted in nginx frontend timeout (504 gateway timeout). I suspect initial file scan of prepopulated data directory was to blame.

Creating a clean database and moving the data directory works, but all users and the established shares get lost this way. This is not really an option for a large installation.