Unable to upgrade from

I am having difficulty upgrading from to 16.07. When I click to open the web updater, it just seems to skip the update process, showing all check marks as if it had already been completed. Clearing browser cache etc does not fix it. I also don’t see any indicator that the updater ran or any relevant errors in the logs.

I’m running
Apps installed: 54
Apps updates available: 3


Version: 7.3.13
Memory Limit: 1 GB
Max Execution Time: 3600
Upload max size: 1 GB


Type: mysql
Version: 10.1.43
Size: 29.2 MB

When I click on settings, this is what I see:

After clicking on Open updater, I get this:

Note that the green checks are already in place when as soon as this page loads, whereas I recall the updater going through these iteratively in previous updates.

If I click on “Continue udpate”, then I just get this:

And then clicking on Go back to your Nextcloud instance to finish the update", I get back to the settings page.

So, for whatever reason it’s not going through the update steps.
Also note that it does not show me the 17.0.2 version in the production channel prior to the update.

Do I need to reset the updater in some way to facilitate getting this unstuck and continuing through a normal update process?
Thank you for any assistance,

A manual upgrade might be a good idea.

It will need you have shell access in other to make the changes.

Did you try incognito mode?, as maybe a cookie is failing to allow the process.

1 Like

Thank you for the reply. I do not have shell access as it is a shared host.
However, I may be able to do this with the occweb extension.

Before I try that, is there a way to reset the web updater from the occ command first and then try the web updater again?

I was able to upgrade manually to with the standard manual upgrade instructions.
Next I was able to SSH into my shared host and, though I don’t have root access, I could run bash scripts from my user account. Here were the bash scripts to use occ to complete the upgrade.
php /var/www/vhosts/mysite.com/httpdocs/occ upgrade
php /var/www/vhosts/mysite.com/httpdocs/occ maintenance:mode --off
This worked just fine.

I got a warning in the admin panel that there were some tables that needed conversion to bigint, so I got back into SSH and ran this:
php /var/www/vhosts/mysite.com/httpdocs/occ maintenance:mode --on
php /var/www/vhosts/mysite.com/httpdocs/occ db:convert-filecache-bigint
php /var/www/vhosts/mysite.com/httpdocs/occ maintenance:mode --off

Seems to have worked fine.

1 Like