Unable to Update to 14 (Docker)


I see the prompt on my nextcloud settings to update to 14 but when I click on it - I just get a white page with nothing on it.

So I attempted to update on the CLI - ran the docked compose pull & occ ./upgrade which reported that I am on the latest version.

I am using a docker compose file setup. Any idea how I can update?


update the docker way?

or use watchtower.


I tried
$ docker-compose pull
$ docker-compose up -d

But it said I already have the latest version.

which image of nextcloud is mentioned in your docker compose file?

I am not sure - this is the docker-compose I am using: https://github.com/nextcloud/docker/blob/master/.examples/docker-compose/with-nginx-proxy-self-signed-ssl/mariadb/fpm/docker-compose.yml

that should be nextcloud:fpm which was updated 22h ago to 14.0.2.
when did you try docker-compose pull… ?

Just tried right now (docker-compose pull) - still on 13.0.6

maybe you can change this line

to image: nextcloud:14-fpm
or what ever version you want to update to.
-> https://hub.docker.com/_/nextcloud/


I had a similiar problem. Using docker-compose according to the update procedure on github (https://github.com/nextcloud/docker#update-to-a-newer-version).

My guess was, that the image is not updated correctly. Adding different flags (nextcloud:15-apache on my server) did not help.

Removing the image by manually on the other side made it update properly.

  • docker rmi nextcloud:YOURTAG
  • docker-compose build --pull
  • docker-compose up -d

Hope that helps, Marc