Unable to update from v17 to latest version

Hi,
When NextCloud v18 came out, I found that it would not should up on the NextCloud settings page listing the update options.
I could upgrade to the latest v17.0.x release from the NextCloud settings page but that was it.
I waited and checked the settings page at various points in time as first I thought it may just be that v18 wasn’t available in the updater yet but still the same result.
I kept on doing updates from v17.0.x release I had installed to to the newest v17.0.x release the page listed but the page still never showed any newer version to upgrade to then that.
This continued to happen even when v19 came out, v20 came out and now v21 has come out.
I just checked the settings page today and it let me know that my v17.0.8 version could be updated to v17.0.10 as shown here:

I then updated to v17.0.10 and opened the settings page and saw this:


This time, it did show an update for a version newer then v17.0.10 but the “Open Updater” button is missing so I’m unable to update to the newer version.
I did try changing the update channel a while ago but that also led to a settings page without an “Open Updater” button.
I noticed that the page shows under warnings “MySQL is used as database but does not support 4-byte characters.” but I wouldn’t think that would be the problem as nothing on the settings page says it’s required for the new version that 8-byte character support is enabled.
Justin

Which operation system and version do you use?
Which MySQL / MariaDB do you use?
I think all is two years old: Nextcloud - Wikipedia

Perhaps you can better re-install.
The alternative is:
upgrade 17 → 18 → 19 → 20 → 21
and between upgrade your operation system and/or PHP and/or MariaDB/MySQL

A software like Nextcloud needs more support than every 2 years.

Right, I forgot about about the system details.
They are:
Operating System: Gentoo Linux
DB: MariaDB 10.5.9
PHP: 7.3
Apache: 2.4.46

It’s been more then a year since I upgraded any of those and I probably need to reinstall Gentoo Linux.
I would think the versions I have should still fit the requirements of NextCloud but I should probably double check that.

@jdunn0 did you try the cli/occ updater?

i just did this some days ago. means: that should work.

i guess updating the OS is the biggest part of the work. maybe you should try that first, especially since there was a profile-upgrade in the meantime (17.0 → 17.1) which required many pkgs to be recompiled. the server-software in itself will most likely not be a problem in the current versions.
GOOD LUCK!

I did not know occ had an update command.
I just looked at the ooc help and then ran the occ update:checkcommand which sent me to the page outdated PHP release v7.1 – Nextcloud.
It’s weird that while the developers put the lack of update reason link in occ, they didn’t include that link in the settings page.

My Gentoo Linux install is still updated past the profile upgrade to 17.1 but there is a python update, X11 update and stuff that have caused a lot of blocks that I think a reinstall will be needed to deal with.

my mistake. it’s not part of occ. it’s a program of it’s own.

https://docs.nextcloud.com/server/21/admin_manual/maintenance/update.html#using-the-command-line-based-updater

Ok, good to know.
Though now that occ update:check told me that my PHP version was too old, I should be able to use the web updater when that issue is resolved.

Edit:
I was able to resolve the issue with the PHP version being too old and was able to use the web updater.
I then updated to v18.0.14 then to v19.0.10, then to 20.0.9 and then now the updater says “Your version is up to date”.
I’m still not on the most recent NextCloud version but I’m a lot closer then before and am using a supported version so that is good.

Edit 2:
I just used the command line updater to update to v21.0.1 so I’m now running the latest version :slight_smile:

1 Like