Unable to update admin personal settings

Nextcloud version (eg, 20.0.5): Nextcloud Hub 3 (25.0.8)
Operating system and version (eg, Ubuntu 20.04): fedora 37
Apache or nginx version (eg, Apache 2.4.25): apache 2.4
PHP version (eg, 7.4): 7.4.33

The issue you are facing:
Trying to save admin personal settings, like email, location etc.
Cannot save, I get response “Unable to update primary email address”. Similar for location etc.
Maybe a permission error on filesystem level?

Is this the first time you’ve seen this error? (Y/N): maybe

Steps to replicate it:

  1. Login as admin.
  2. Goto settings
  3. Goto personal. Type new email.

The output of your Nextcloud log in Admin > Logging:

Nothing related because I cleaned the log

The output of your config.php file in /var/www/html/nextcloud/config/config.php (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'o',
  'passwordsalt' => 'Z',
  'secret' => 'O',
  'trusted_domains' => 
  array (
    0 => 'localhost'
  ),
  'datadirectory' => '/var/www/html/nextcloud/data/',
  'dbtype' => 'mysql',
  'version' => '25.0.8.2',
  'overwrite.cli.url' => 'http://localhost',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nc_admin',
  'dbpassword' => 'dbpass',
  'installed' => true,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 3,
  'log_type' => 'errorlog',
  'logfile' => 'nextcloud.log',
  'default_phone_region' => 'FI',
  'mail_from_address' => 'nextcloud',
  'mail_smtpmode' => 'sendmail',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'nextcloud.homenet',
  'app_install_overwrite' => 
  array (
    0 => 'ocsms',
    1 => 'ocr',
    2 => 'files_external_gdrive',
  ),
);

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

PASTE HERE


Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

PASTE HERE

My problem is, i can’t save Notes, or user personal info (like email) either.
I have enough disk space. I tried selinux disabled.
Where should I start debugging. I tried to check all the logs but because I couldnt find a clear error I’m not sure if i checked enough logs.