Unable to lock ./ibdata1 in docker-compose setup

Nextcloud version: 20.0.7
Operating system and version: Ubuntu 20.04

I run Nextcloud in a docker-compose setup. Now for the second time, a process must have got stuck or something, because after rebooting the host OS, my database doesn’t come up anymore.

The relevant section of the compose file looks like this:

    image: mariadb
    container_name: nextcloud_db
    command: --transaction-isolation=READ-COMMITTED --binlog-format=ROW --character-set-server=utf8mb4 --collation-server=utf8mb4_general_ci
    restart: always
      - db:/var/lib/mysql
      - nc.env
      - "traefik.enable=false"

The error I’m seeing is this:
[ERROR] mysqld: Can't lock aria control file '/var/lib/mysql/aria_log_control' for exclusive use, error: 11. Will retry for 30 seconds
When I move the aria_log_control file to a backup location and restart the container, the error changes to:
[ERROR] InnoDB: Unable to lock ./ibdata1 error: 11 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.

This can not be solved the same way because as I understand ibdata1 is essential for the database’s operation.

I have encountered this before and was only able to get my installation back on track by basically starting from scratch and replacing the user data with a backup (lost every calendar & plugin on the way though). I’d like to do better this time (I have already disabled automatic software updates on the host machine which in my opinion are likely to cause the issue).

Is there any way to make mariadb accept its ibdata1 file again?
Any help is greatly appreciated.