Unable to load dynamic library 'pdo_sqlite' (Nextcloud 15.0.2 | PHP 7.2 FPM | Ubuntu 18.04)

linux_question
php

#1

Getting the following log entry when opening the log view in the backend:

PHP Startup: Unable to load dynamic library 'pdo_sqlite' (tried: /usr/lib/php/20170718/pdo_sqlite (/usr/lib/php/20170718/pdo_sqlite: cannot open shared object file: No such file or directory), /usr/lib/php/20170718/pdo_sqlite.so (/usr/lib/php/20170718/pdo_sqlite.so: undefined symbol: php_pdo_unregister_driver)) at Unknown#0

My Server:
Ubuntu 18.04
PHP 7.2.14 using FPM with NGINX

I had to enable the “pdo_sqlite” library in the /etc/php/7.2/fpm/php.ini because i need it in another project.

I did it the “recommended” new way with removing the “;” at the beginning of the following line:

extension=pdo_sqlite

Also i have checked the file “/usr/lib/php/20170718/pdo_sqlite.so” and it does exist.

I am using the “ppa:ondrej/php” Repository to keep up with the newest PHP updates.

I have already restarted all the services (NGINX, FPM) and the whole server just to be save but its not going away.

Any ideas what this could be?

With best regards.


#2

I only could resolve the issue after i commented out the pdo_sqlite extension again in the php.ini.

Since i dont need the sqlite extension any more for my other project, this solved my issue.

In my opinion not the “correct” solution but i dont know what causes it.