Unable to load dynamic library imagick.so.so

Support intro

Sorry to hear you’re facing problems :slightly_frown

Some or all of the below information will be requested if it isn't supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 25.0.1
Operating system and version (eg, Ubuntu 20.04): rpi Linux pi4 5.15.76-v8+ #1597 SMP PREEMPT Fri Nov 4 12:16:41 GMT 2022 aarch64 GNU/Linux Apache or nginx version _(eg, Apache 2.4.25)_: Apache2 2.4
PHP version (eg, 7.4): php8.0

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. PHP on startup and daily in the log

The output of your Nextcloud log in Admin > Logging:

PHP Warning:  PHP Startup: Unable to load dynamic library 'imagick.so' (tried: /usr/lib/php/20200930/imagick.so (/lib/aarch64-linux-gnu/libgomp.so.1: cannot allocate memory in static TLS block), /usr/lib/php/20200930/imagick.so.so (/usr/lib/php/20200930/imagick.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

I research all this internet pages and didn’t found a solution.
have installed and updated everything and installed php-imagick
and the file above exists.

Any Idea?

Have you tried to use the search function of this forum. Several matches can be found which are referring to the same error message:


Of course, I did. But nothing helped to solve my issue.

Of course i did, however, all the actions and workarounds doesn’t fit my problem

I think the error message “Unable to load dynamic library 'imagick.so'” is stating what the problem is. First make sure that you’ve installed the php8.0 imagick module. IF this has been confirmed, make sure that all libraries, which are required by the php module, are also installed on your server.

NO THATS NOT. php8.0-imagick is installed and all the other dependencies …

If you cannot contribute, leave it …