Unable to generate share from exising share

I have 3 external mounts which Admin is sharing with my own (personal) account. When I try to re-share a sub-folder in those shares it doesn’t complete the process:

The wheel keeps spinning for the ‘Share link’.

If i check the database directly I can see a new entry in nc_share:

And when I manually create the URL with the token I do get access to the shared folder. But when I go back to NC and want to check if the shared folder settings are there it comes back blank.

Did you enable re-sharing in the sharing settings?
I have just tried that and it worked without any issue. NC 10beta, btw…


Hi Budy,

Yes I did. So I can re-share when i login as myself (instead of Admin), but like I said, once I tick the box for generating a share, it just shows the busy icon and doesn’t stop, but the DB is showing it being created. When I then refresh the page, it shows like no share has been created, but DB still shows it, and I can still access it using the token in the DB.

I am not sure what the best data is I can provide to show the problem.

Well, me neither… unfortuanetly. I guess, you will have to create an issue on Guthub for this. There will likely be something in the log, but I wouldn’t know what to look for.


Thanks, I have raised issue 585 for this.

Has anybody else verified if this works for them? I have done a clean install on 9.0.53 and still have the same symptoms as in post #1. I don’t know if it makes any difference that my shares are external shares, not local ones.

At this moment this is blocking me for opening it up for anybody else.