Unable to finish update to 13.04

After updating to 13.04
I used the web updater to update from 13.02 to 13.04.
There was a small problem (, but after restarting the update everything went fine.
After starting th uptdate finisg on the login-page I got following messages

Suche nach einer Aktualisierung für die App “activity” im App-Store
Detaillierte Protokollmeldungen
Update vorbereiten
Log-Level auf “debug” gesetzt
Wartungsmodus eingeschaltet
Das Datenbankschema wird aktualisiert
Datenbank aktualisiert
Suche nach einer Aktualisierung für die App “activity” im App-Store

After this last message (something like “Looking for an Update for the App ‘activitity’ in the App-Store”)
the procedure stops. After a while there comes a message like “something went wrong, please reload the page”.

Is there anybody, who can help me, to get my Nextcloud running again?
I’m using Nextcloud on hired webspace; no possibility to do something on the command-line!

Nextcloud is fine, but I had no Updates without problems!
The Update from 12 to 13 killed my complete installation.

PS 2
After several times resetting the Maintenance Modus in config.php the update-finishing-procedure finished and the Login-Screen reapeared.
But the returning problems in the Update-Procedure reduce the Usability of Nextcloud.
(it took me about five hours …)

And what happens then? The Updater tells you what to do, but (idk you dont tell more about it) maybe it works after reloading the page?! Nothing in the logs?

That looks like low memory for php or the apache software, that could results bottlenecks while updating (the update process needs very much memory, because it checks integrity and makes backups and so on.
You can check php settings with a .php file. This should be in the php file:


This can be a result of

and results in

,because every webspace has other settings with different server setups. They make money with one system on which runs more then one webside. So there are limitations. On V-Servers or other hired servers you have the memory and the rescources in a virtual machine and the advantage is, that you can use the command line with commands :wink:

Thanks STrike for the useful comments on my update-problems!
V-Server could be an option…:frowning_face:
But in the meantime we are experimenting with a Nextcloud on a Raspberry Pi 3 B+.
Untill now this works perfect (with six users and one superuser; low load).
We will see …

RPi is a nice low-slung hardware which is inexpensive.
I use such system, too. For just the filesync and Card-/CalDav its very nice.
But when you looking forward with Collaboration Office or Talk it will be very hard for the small rpi. But for my use cases I’m satisfied.

I encounter the same problem. It stuck on the same point for the update. I’m on a shared host, too. But until now i never had problems with updates.
I hope get it managed by trying it several times :wink:

Could this help here? https://help.nextcloud.com/t/fehler-nach-update-auf-12-0-1/19229/7

I do not understand what the solution does, but i cloud try it… :wink:

Ok, I can’t, because there is nothing like /nextcloud/apps/files_accesscontrol/lib/Operation.php in my Installation. Seems like something very different…

Try to delete the app. Delete nextcloud/apps/files_accesscontrol/

And then try to update again.
If the update is successful reinstall the app files_accesscontrol vom the appstore via “apps“.

Ok, i should have written that there is even no folder nextcloud/apps/files_accesscontrol/, it seems like i don’t have such an app. So the Solution from the link will not solve my problem.

I removed now the “activity” folder from the apps folder, because it stuck on that point doing the Update, but it does not help.

Whats then new? Where it is stucking? If you dont want to find the responsible mistake for this behavior you can do a manuel update. This is also on hired providers possible without access to command line.

I want to summarize:

I had the same Issue then the Thread-Opener. I restarted the Update several times. But it always did stop after “Looking for an Update for the App ‘activitity’ in the App-Store”".

I could not fix it by removing folders from the “apps” directory and i was not able to login into the nextcloud-instance again, because the update already was started.

I solved the Issue now by making a parallel installation of nc 13.0.4 via the web-installer. Then i changed the folder name to the one of the original installation and copied the config-file. I renamed the original installation of course and did not delete it.

In this new Installation the Update went threw, but the first page for the User could not be displayed (all user data were missing, i think this caused that behavior).

Afterwards i changed the foldernames of both Installations again. Then i was once more displayed wit the “start update”. But then the Update finally worked. I think the “beside update” threw this unconventional way fixed something in the database.

Finally my cloud runs againe :slight_smile: