Unable to find TOTP app

I have another Raspberry PI 4 on which I can test, but I need at least to connect it to an USB disk.
Which image did you use?

thanks for confirming that you are NOT using NCP, but manually installed Nextcloud.

I was trying to determine if this is an issue of the NCP updater or a general NC update bug.

Lots of people use NCP in production, and there are many extras that are not present in vanilla NC. Of course it is a matter of preference, but nothing wrong with NCP in production.

On the contrary, stuff like auto backups and snapshots are very highly appreciated by users.

I’m sure there is nothing wrong with NCP, but I prefer avoiding installers and have full control of what I install. Just a matter of preference.

sure, just want to write that so other people don’t think there’s something wrong with NCP in production :+1:

The image is: NextCloudPi_RPi_11-27-20 (Raspberrypi OS ARM64)

Documentation

For testing you can use only the microsd card

I’m sure I’ll test it.

But the issue with vanilla Nextcloud remains.

ownyourbits.com/downloads

yeah that’s the main point of this thread :frowning:

Thanks. This is a different issue, I don’t have that entry in config.php

And thats why Nextcloudpi is in V 20.0.4 at this time

yes, won’t push the autoupdate for everyone until we make sure it works

I don’t have it neither

Phew, I’m glad I’m not the only one who’s missing apps in 20.0.5’s app store. Looks like I have to be less careless with installing NC updates in the future…

I have the same issue. But i am using debian 10 over pi4. On nextcloud.log appear a very big error that wasn’t able to display on the web. I display on the console and start like this:

{“reqId”:“Q************”,“level”:2,“time”:“2021-01-19T22:30:56+00:00”,“remoteAddr”:“fd69:",“user”:“server”,“app”:“appstoreFetcher”,“method”:“GET”,“url”:"/settings/apps",“message”:{“Exception”:“InvalidArgumentException”,“Message”:“ser
ver version is invalid”,“Code”:0,“Trace”:[{“file”:"/var/www/nextcloud/lib/private/App/AppStore/Fetcher/AppFetcher.php",“line”:119,“function”:“isCompatible”,“class”:“OC\App\CompareVersion”,“type”:"->",“args”:[“7.3.19-1~deb10u1”,“5.6”,">="]},{“file”:"/var/www/nextcloud/l
ib/private/App/AppStore/Fetcher/Fetcher.php",“line”:187,“function”:“fetch”,“class”:“OC\App\AppStore\Fetcher\AppFetcher”,“type”:"->",“args”:[“W/“2021-01-19 18:07:06.931562+00:00"”,”[{“id”:“defaultlinkopen”,“categories”:[“customization”,“tools”],“userDocs
“:””,“adminDocs”:"",“developerDocs”:"",“issueTracker”:“https:\/\/github.com\/blizzz\/DefaultLinkOpen\/issues”,“website”:"",“created”:“2018-01-11T22:23:44.709327Z”,“lastModified”:“2018-11-30T23:07:35.466423Z”,“releases”:[{“version”:“1.2
.0”,“phpExtensions”:[],“databases”:[],“shellCommands”:[],“phpVersionSpec”:"
",“platformVersionSpec”:">=13.0.0 <16.0.0",“minIntSize”:32,“download”:“https:\/\/github.com\/blizzz\/DefaultLinkOpen\/releases\/download\/v1.2.0\/defaultlinkopen.tar.g
z”,“created”:“2018-11-30T23:07:35.457036Z”,“licenses”:[“agpl”],“lastModified”:“2018-11-30T23:07:35.567657Z”,“isNightly”:false,“rawPhpVersionSpec”:"
",“rawPlatformVersionSpec”:">=13 <=15",“signature”:"
**=”,“translations”:{“en”:{“changelog”:""}},“signatureDigest”:“sha512”}],“screenshots”:[],“translations”:{“en”:{“name”
:“Default Link Open”,“summary”:“Restores browser default behaviour in opening links in comments”,“description”:"Since Nextcloud 13, links written in comments are formatted and thus clickable. However, they wil

After that appear lot of random translations and checksums (?)

Maybe InvalidArgumentException: server version is invalid · Issue #25137 · nextcloud/server · GitHub

Nextcloud version : 20.0.5
Operating system and version: Debian 10.7
Apache: Apache 2.4.38
PHP version: 7.3.19-1

Same issue here. After manual NC update from 20.0.4 to 20.0.5 (download from Changelog – Nextcloud) TOTP app is missing in 20.0.5. The app wasn’t installed within the update process, which means that all users using 2FA-TOTP could not login anymore and had to use the backup codes. The app can not be found anymore in NC 20.0.5.

I manually solved the issue by copying the app from the old 20.0.4 backup to the app-folder in 20.0.5.

I’ll wait to update my other productive installations until the issue is solved.

Definitely a NC bug

1 Like

Yes thanks. Unfortunately it looks like this is still an open issue they are working on:

I can confirm that it works fie again in 20.0.6. All apps are shown and the log doesn’t inflate anymore (which is a natural consequence).

Edit: I was too quick with my confirmation, as it seems. The app store still seems to have issues in NC 20.0.6, but other ones. I have the same four php errors in my NC log over and over again when accessing the app store:

Error: Invalid argument supplied for foreach() at /var/www/nextcloud/lib/private/Installer.php#414
Error: array_values() expects parameter 1 to be array, null given at /var/www/nextcloud/lib/private/App/AppStore/Fetcher/AppFetcher.php#162
Error: array_filter() expects parameter 1 to be array, null given at /var/www/nextcloud/lib/private/App/AppStore/Fetcher/AppFetcher.php#162
Error: Undefined index: data at /var/www/nextcloud/lib/private/App/AppStore/Fetcher/AppFetcher.php#162

I also observed that the app categories in the side bar aren’t shown anymore and that the search function yet again doesn’t find all available apps (not even all the installed ones). Which is strange because I’m quite sure that the app store worked again after the update to 20.0.6.

1 Like

I have this exact same issue on 20.0.7