Unable to enable Apps on Nextcloud 11.0.2

Hello there,

I’ve upgraded Owncloud 9.14 to Nextcloud 11.0.2, I can upgrade with no errors but when I need to enable Apps on Nextcloud I got some errors like this.

cURL error 51: SSL: certificate subject name ‘*.certname’ does not match target host name ‘github-cloud.s3.amazonaws.com

Could someone have this experience let me know how can I fix it?

I’d like to enable Two Factor TOTP Provider Apps on my server.

Thank you in advance.

I’ve found I got this error when my nextcloud admin user was different or non-existant to my samba user account, ie I had no admin user in samba. I was sync-ing users to nextcloud. Basically, the error meant nothing, except there was an issue. Sent me down dozens of dead ends. I’m not saying your issue is the same as mine, I just got that exact same error log message and the symptom was I couldn’t enable apps, the fix was to add a sambaAD user called “admin” with the same password as nextclouds “admin”. Hope this helps


Thank you for your reply, I’ve tried from your suggestion but I’m still can’t to enable apps.

Anyone have any ideas?

Thank you in advance.

Can you ping github-cloud.s3.amazonaws.com in your server’s terminal, if you can not ping this doman maybe your firewall or some reason you just can’t reach the apps server. I had this issue was because the damn china GFW blocks this sites.
when I tried connecte through a proxy server ,it’s ok.

Thank you for your reply.

I can ping github-cloud.s3.amazonaws.com but still can’t enable Apps