Unable to delete files, maintenance mode

I just installed nextcloudpi in an raspberry connected to a 16Tb usb drive.
The installation worked fine, I have added a couple of users and alla are able to upload their files.
Bur none of them can delete any files.

This is the system info

NextcloudPi version v1.51.0
NextcloudPi image NextCloudPi_RaspberryPi_v1.51.0.img
OS Debian GNU/Linux 11. 5.15.61-v8+ (aarch64)
automount yes
USB devices sda

If I try to delete files in the app I get a response that “Server is in maintenance mode”.
According to the setting it is not. I tried to put it in maintenance and remove it bur that didnt help.

I get som errors in the log but Im not sure its connected to this.

Exception: Call to a member function getUserId() on bool in file ‘/var/www/nextcloud/apps/text/lib/Controller/SessionController.php’ line 116

  1. /var/www/nextcloud/lib/private/AppFramework/App.php - line 172:OC\AppFramework\Http\Dispatcher->dispatch()
  2. /var/www/nextcloud/lib/private/Route/Router.php - line 298:OC\AppFramework\App::main()
  3. /var/www/nextcloud/lib/base.php - line 1047:OC\Route\Router->match()
  4. /var/www/nextcloud/index.php - line 36:OC::handleRequest()

Caused by Error: Call to a member function getUserId() on bool

  1. /var/www/nextcloud/apps/text/lib/Controller/SessionController.php - line 91:OCA\Text\Controller\SessionController->loginSessionUser(“*** sensiti … *”)
  2. /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 225:OCA\Text\Controller\SessionController->sync()
  3. /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 133:OC\AppFramework\Http\Dispatcher->executeController()
  4. /var/www/nextcloud/lib/private/AppFramework/App.php - line 172:OC\AppFramework\Http\Dispatcher->dispatch()
  5. /var/www/nextcloud/lib/private/Route/Router.php - line 298:OC\AppFramework\App::main()
  6. /var/www/nextcloud/lib/base.php - line 1047:OC\Route\Router->match()
  7. /var/www/nextcloud/index.php - line 36:OC::handleRequest()

Any ideas what to do?

Almost the same here, I can delete small files, but none larger than 2.8 MiB, the message “Connection to the server lost*” appears. (*Verbindung zum Server verloren)

By the way, the displayed memory allocation is incorrect, and it does not change anymore.

I am trying out two version at the moment, none works as intended.
I have the nextcloudpi where I cant delete files.
I also have one instance on a truenas, there the trouble is that I cant login from the app plus that for some wierd reason some computers/mobiles cant reach the login page?
I tried it on different machines on same and different ssid. 2 different computers on the same where one can reach nextcloud but not the other, same with 2 mobiles on same wifi.

Really random

1 Like