Unable to connect to server after client upgrade to 3.4.4 on MacOS 10.15.7 (Catalina)


after upgrading to client version 3.4.4 on my Mac (10.15.7 Catalina) the client is no longer able to connect to my server. Web and iOS client access is working without problems.
The existing connection from former version was not able to connect. I got no failures. I deleted the existing connection and tried to re-add the connection, but I’m not able to connect too.
I add the server address and click on “Weiter”/“Continue”. After that I get the failure
After clicking on “Andere URL wählen”/“Choose another URL” I come back to server address dialog and see the failure.

“Die Verbindung zu Nextcloud auf https://nextcloud.xxx konnte nicht hergestellt werden:
Im Ablauf des SSL-Protokolls ist ein Fehler aufgetreten” /
“Unable to connect to Nextcloud on https://nextcloud.xxx:
An error occurred in the SSL protocol flow.”

I would be very pleased, if somebody knows how I can fix this problem?

Kind regards


I think I have found the problem. I re-enabled TLS 1.2 on server side. Now it works.
The question is what has changed in 3.4.4? Because the older client version had no problems with TLS 1.3 only webserver.