Unable to connect to nextcloud box via SSH

HI, I’m new to the forum and have spent sometime trying to solve 3 issues with my nextcloud. The first I think is solved for now because I am at the same point that I was at the weekend before it died and had no access via browser. However, I still have two issues which may be connected.

The first is that the box is not visible on my home next work, which is strange if I can access it via the browser (in my mind anyway).

The second issue is that I am unable to access the box via terminal (I am using Kubuntu 16.04.1). I have followed the instructions in the wiki and the the box is actually listed but trying to access is blocked. I have typed both the one in the instructions and my personal one but denied.

I am sure the answer is simple and I am missing something but in I am in new territoriality.

Many thanks

is sshd running on that box and did you check iptables rules, if there is any set?

Hi,

yes the sshd is running on the laptop I have just tried logging into kodi running on a raspberry pi no problem. I am currently unable to reach the nextcloud box through my browser for some reason although the lights are flashing. Had no problem last night. Not sure how to check iptables at the moment but will be learning that tomorrow.

Thanks

Ashley

No i meant if sshd is running on the server in your case the pi.

What error do you receive when trying to ssh into the NCB?

  • Are you using IP or hostname
  • Does it show up under DHCP lease in your router

Dev0
Sorry, at first I thought you meant the pi but then for some reason I thought you meant the laptop.

The answer is I don’t know. It is possible to hook it upm like a normal pi set up, I did a search and couldn’t find the answer to that but I may have missed it somewhere. I tried connecting it up to the monitor but got a blank screen.

JasonBayton,

I used both IP and hostname with the same result

I didn’t check that, sorry, I will check that tomorrow when I get the password (I’m not the admin on that at the moment).

I currently have the box turned off at the moment as I was unable to connect earlier, tried several times. I had the same problem as before. It worked at first through the browser then the next day when I turn the
Laptop on I get nothing despite the hardrive light flashing but not much happening with the pi, just a solid red light and occasional green light. Same result with two different pig’s.

a blank screen may be the screensaver it it started the x-server. So you should hook up a mouse and keyboard too.

Ok, I connected up to the pi as normal and carried out the update as described on the wiki home page.

I now have nextcloudbox showing up in the browser but not on the network listing in my file manager.

It is listed as DHCP on the router

I checked if sshd is running and got this
1126 0.0 0.4 8072 3800 ? Ss 09:43 0:00 /usr/sbin/sshd -D
1784 0.0 0.4 11864 4640? Ss 09:45 0: sshd: ubuntu [priv]
:u 1846 0.0 0.2 11864 2408 ? s 09.46 0:00 sshd: ubuntu@pts/0
:u 4291 0.0 0.0 2164 568pts/0 s+ 10:21 0:00 grep --color=auto sshd

hope that is more useful and answers the questions asked