Unable to change elasticsearch connection URL

I installed and enabled the fulltextsearch app with elasticsearch search platform.
But I am not able to edit the ‘Address of the Servlet’ in the fulltextsearch settings.
The edit box appears read-only and not allow editing.
What am I missing?
I am using nextcloud 18.0.4 running on Respbian Buster.

I answer the question by myself. Please ignore the post. It’s my mistake. There is no issue editing the URL.