Unable to add files - nginx/php-fpm vhosts in separate fpm pools

First off thank you for reaching out to me on Mastodon (also, very slick on-boarding for this support category. Cool forum s/w). I love gnu/linux and the notion of federation and want it to take over the world! So far, that’s actually going quite well actually :slight_smile:

This is Not urgent at all. I’m just playing and hoping to deploy my own public instance at some point.

I installed syncloud on my box at home and it was very slick using a vm. Works perfectly. Great install docs too.

Next I tried it on a vps at Contabo in .de where I have two vps. I included the bit about separate pools for vhosts in the subject, because I suspect that may be where my problem lies (but I could easily be wrong about that! :wink: ). I do want to mention that the install there was very slick too. The complaints about its php env were clear and every time I made a change and reloaded nginx/php-fpm they went away one by one. You all have done an amazing job on that and the docs.

“Not enough free space, you are uploading 520 KB but only 0 B is left” is an example error that I get when trying to add a file. Quota is not activated.

df -h: /dev/vda2 492G 89G 378G 20% /

gemlog 13-1305 nextcloud>lsblk
vda 253:0 0 500G 0 disk
|-vda1 253:1 0 237M 0 part /boot
`-vda2 253:2 0 499.8G 0 part /

I have been using nginx and php-fpm for about 5 years now. I switched from apache (rightly or wrongly) just to get easier user separation. I have nothing against apache and used it for like 10 years, it’s just that both servers have nginx (they back each other up) and proxying apache behind nginx is a bit of a pita and extra load. So… I went against your advice and installed it using nginx. I recognize that I’m the author of my own misfortune and thank you for offering to help me despite that.

Nextcloud 12.0.0
Ubuntu 16.04.1 LTS
nginx/1.10.0 (Ubuntu)
“No server logs
Everything is working fine”

I’ve been using a slightly modified version of this script for about 5 years now to set up new vhosts and separate fpm pools http://preview.tinyurl.com/cfdylur . It works wonderfully btw.

?? "The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):"
A config.php file doesn’t exist in /home/nextcloud/public_html

It is up and serves me the default content just fine at https://nextcloud.gemlog.ca

I already have 1.5M of logs, which is crazy. Maybe there is something you want me to grep for?

I think that’s all I can tell you about the install and my problem.

p.s. I’ve just noticed that video has the same bug I had in syncloud: no way to close the player window. I know how to fix it, but that should be addressed in the distribution right away.

I was invited to post here. I thought I did a complete job via the guidelines.
Like I said, on masto and above, I know I tried to use nginx (for reasons) and not the recommended apache, so I wouldn’t normally have sought any support if not invited.

How did you install Nextcloud?

I don’t understand where you get the error with the output of your config.php and that the default login page seems to work?

Nginx has community support and is also used by enterprise customers. I’m not sure if you put the recommendations from the documentations into your nginx-configuration: https://docs.nextcloud.com/server/12/admin_manual/installation/nginx.html?highlight=nginx

If you use different fpm-pools for each setup, you have to adjust the permissions of each setup, but I think it should work in general.

I don’t understand where you get the error with the output of your config.php and that the default login page seems to work?

A config.php file doesn’t exist in /home/nextcloud/public_html

There is no error from the output of the config.php file, because the file doesn’t exist!

It wasn’t created, which is why I think nextcloud isn’t running as the correct user. I have a couple of dozen sites across two vps using https and nginx with the same/similar setup for each site. They are all running as separate users via php-fpm.

Yes, I did try and follow all the relevant help for nginx and in that individual config. Thank you for replying me.

How did you install Nextcloud?

I cp’d it over, chowned/chmoded it and got going. The usual way as far as I know. Sorry I missed that question.