Unable to add external storage on a Docker installation

Hi everyone,

I’ve been struggling for the last days with accessing my files in Nextcloud .

I manage to install the latest image of Nextcloud with Docker on a Synology NAS.

Everything works ok with uploading images, but I want to access my files from the NAS.

I mounted the folder where my NAS files are, in the Docker image, and in Nextcloud I added the external storage. I can see it in the files section but when I tap on it I cannot access it and I get this message: *This operation is forbidden. And this is what I see in the log:

Fatal	webdav	OCA\DAV\Connector\Sabre\Exception\Forbidden: No read permissions

I added other folders as well and sometimes I don’t get the message but I cannot see the files.

I also checked the file permissions and they are set on 755 to www-data:www-data.

Another thing I tried was to copy the files outside of Docker to the folder where the user stores the Documents and Photos. But those files aren’t visible as well…

To install the image I followed this tutorial: Synology: How to Install Nextcloud Using Docker – Marius Hosting

Any ideas where to look into this?

Note that I tried using the 18.0.0 version and that seemed to work.