Unable to add content/folders to sub folders on S3 storage

Nextcloud version24.0.5
PHP version 7.4 and 8.1

I have an issue where I can create folders and upload files on the S3 storage root but if I navigate to a sub folder I presented with “You don’t have permission to upload or create files here”

If I upload files to the root I can then move them into a subfolder.

Any advice would be greatly appreciated.


Hi @james22, I’m getting the very same thing. I can create nested folders directly in the bucket, but like you not in nextcloud.

Did you ever get a resolution to this by any chance?

Kind regards


Hi @deljones, I haven’t been able to figure it out yet.

I spent a bunch of time testing different things to no avail and this was my last resort hoping someone might be able to shed some light. It doesn’t make sense to me as the permissions are clearly correct as you can move stuff into nested folders in nextcloud but not create/upload directly.

Seems like a bug but not sure where to go from here. I had been hoping to move us from OneDrive/Sharepoint but this is a showstopper at the moment.

I haven’t yet gone through disabling other apps to see if there is a conflict so will try that once I have time.


@james22 same here. I’m actually playing with it now to get it working but nothing. I’ve stuck up a request for help with this too, I guess we just have to wait and see, but time is pressing!

Oh well. If I get anywhere I’ll reach out to you again.

Have a great day


@james22 I have the space and resources so I installed a fresh Nextcloud. External Storage is already enabled. I set up a connection which worked ok. I then attempted to create sub folders and it worked! However it was short lived as I tried another and got the dreaded warning.

It seemed time dependent, I know that it doesn’t help us but it did work but only for like 30 seconds

I’m on a different machine but I’ll do a screen grab to show that it did work!

Keep trying


That’s something at least! I haven’t been able to get back on to it again yet so nothing to report. Who are you using for your storage? I’m testing with idrivee2 at the moment.

@james22 Well well well… How about that… The same.!!

They had or have a special 4 bucks for the first year deal so I signed up…


Just had some time to setup and test with Scaleway and works without an issue so it’s something to do with the idrive setup, just need to figure out what now! :slight_smile:


@james22 thats a pity… well looks like the iDrive deal will bite the dust!


Hi @james22 here is some more news:

@srjmas hello…

I raised a support ticket with iDrive two days ago:

This was their reply:


The public buckets feature is temporarily unavailable. It will become available in a couple of weeks.


  • Thanks,*
    Your IDrive Support Team

Keep us posted if you have more.

Thanks very much


I haven’t done any more testing but not sure that would resolve it as the public feature would make the contents public if I understand correctly?

I’m most likely going to bring a storage server online and then use that which should do what I need for now, I just need to set the time aside to set it up, I have it sitting ready.

@james22 Fixed… See this from iDrive:

Dear User,

Thank you for choosing IDrive® e2! We would like to take this opportunity to share what’s new.

Make your buckets public!
IDrive® e2 users with a paid subscription can now enable public access for their buckets. No more waiting for customer support to review and approve the public access requests for buckets.

Follow the simple steps to verify your email address and phone number via one-time verification code and assign public access.

This feature is currently available only for paid IDrive® e2 users. Upgrade your free subscription now and get 90% Off on first year! Annual plans start at $40.00/year $4.00 First Year for 1 TB storage.

Tested and works… Few…

All the best dj

Thanks for updating, that’s good news! I’ll give that a go too.

Happy New Year!