Unable to add a mail account (infinitely loading)

Hello!

A week ago I setup nextcloud on my unRaid server. I am now self-hosting nextcloud. It’s working great except I can’t seem to add my personal email to the mail app within nextcloud.

I am clicking on ‘Manuel setup’ and typing in all the correct mail settings. It seems like it’s adding it but never loads anything. It’s just stuck loading infinitely. I’ve tried searching on google for a solution but have come up short with a fix.

Let me know if I need to post logs (not sure how to do that) or do whatever to help give enough info to make solving this easier.

The email I am trying to add is very new so it should not take long to add it.
There are only like 10 emails in it.

Thanks so much for the help! I really want to add my email to nextcloud :slight_smile:

The screenshot itself looks good, but you haven’t provided any valuable information, about your environment, the used software versions, DETAILED information what you’ve entered in the mail account setup fields, which IMAP and SMTP server you’re using, which related messages have been written to the Nextcloud log file, etc., etc.

Due to the fact that the mail app loads the full IMAP folder tree structure on every start, it is e.g. essential to use a fast IMAP server, like e.g. Dovecot-IMAP. Other IMAP servers are very often not able to provide all requested information within the timeout window.

You’re right. Sorry about that.

environment

Not sure what you mean by this. Do you want to the know the specs of the PC unRaid is installed on?
i5 6500 | 16GB RAM | GTX 1060

software versions:

Nextcloud version: 20.0.2 > Docker on unRaid version: 6.8.3

Mail settings:

Nextcloud log file

Screenshot 2020-11-23 131138

Not sure how to output the file. New to linux
“OCA\Mail\Exception\MailboxLockedException” seems concerning.

Let me know if you need more info. Thanks

Ok, that all looks good to me. I’ve also checked the used IMAP server and based on the reply it seems to be Dovecot, which is ususally extremely fast to me. To find out what’s going on on your IMAP server in detail, you should enable debug logging for Dovecot IMAP. I think the locked-messages are definitely been cause by your server and not Nextcloud.

# telnet dal01.mithrilnetwork.com 143
Trying 67.222.142.74...
Connected to dal01.mithrilnetwork.com.
Escape character is '^]'.
* OK [CAPABILITY IMAP4rev1 SASL-IR LOGIN-REFERRALS ID ENABLE IDLE NAMESPACE LITERAL+ STARTTLS AUTH=PLAIN AUTH=LOGIN] Dovecot ready.
...

BTW, you should check your Dovecot configuration, because currently AUTH=PLAIN/LOGIN are allowed without having a secure connection established :wink:

Thanks for looking into this. How would I go about checking my Dovecot configuration?
I pay for a hosting / email through a 3rd party. (HostKoala)

Would I look at those settings within their cpanel?

Sorry, I don’t know cpanel, so I couldn’t help you any further on this. It might be a good idea to contact the help desk of your hoster and ask for help.