Unable to activate SSH access

Hello guys!

I have been playing around with the NextCloudPi image for some time now with my RaspberryPi 3B+. As I would like to store my data on 3.5" SATA drives, I now upgraded my hardware to an Odroid HC4 with two SATA ports and downloaded the HC4 NCP image.

When I boot up the Odroid for the first time, everything loads and I can access the activation page via my browser. When I save the two passwords for ncp und nc I am redirected to the web interface - so far so good!

From here on, the Odroid image differs from the RPi image. On both versions, the Pi/Odroid tries to automatically log in after boot (seen via HDMI cable connected). On the RPi version it tried to login as user “pi” which still had the standard password “raspberry”. Thus I got the error message “This account is currently not available”. This was new in v1.50.5. The workaround with the RPi was to just connect to the web interface, setup SSH access and change the password of the user pi. Then I could login directly on the pi and change the password again and voila - I had access via the user pi (directly and via SSH).
The problem with the Odroid version is that the user “pi” does not exist. Instead, the Odroid tries to automatically login as root user. This again fails with the error message “This account is currently not available” - presumably as the root user still has the standard password “1234”. Problem is that I cannot follow the same workaround as with the RPi version, because if I try to setup SSH access and change the password for the root user via the SSH-app in the web interface, it gives me the error message “Refusing to use the root user for SSH. It’s insecure”.
I tried to activate SSH for the ncp user which seemed to work. The web interface gave me positive feedback and I can login as ncp user via SSH but the Odroid immediately terminates the connection again with the error message “This account is currently not available”. Same happens when I try to login as root with pw 1234 via SSH…

It seems to me that I have no possibility to somehow connect to my Odroid! Can anyone help?

Thanks in advance!

Best regards!

Can you try and enter ncp in the SSH activation page?

Make up a new password and enter it in the field on the SSH activation page and run it, afterwards use these credentials to login on your device. This will also become the password for the admin web interface afterwards so please remember it.

Unless I’m mistaken we will implement a way to create a new user but it isn’t there yet

The pi user doesn’t exist in Raspberry Pi OS either anymore


The implementation for creating a new user seems to have been missed, for now try with ncp, though this user shouldn’t be used later on as it’s the web admin. So when you change the password for this user there you also change the password for the admin web interface

1 Like

Whilst I understand the pro security standpoints on everything, this makes for an egregiously harrowing experience when the end user attempts to handle anything related to even getting this set up. Lord knows I’ve been fighting with this same issue for 4 days now and have about 13 hours into proverbially smacking my skull into a wall, over and over again. So, after one does the NCP route workaround that’s mentioned, it STILL does not let one create a new user via nc-ssh, as it’s outputting “$USER does not exist” when attempting to create a new user after that from the web GUI, and if one attempts to login directly on the Pi/via SSH in any way, it will STILL close out the connection stating “No directory, logging in with HOME=/”, and then “This account is currently not available” on the next line, and then goes right back to “nexctloudpi login:” afterwards… Over, and over this happens. Is there no solution in sight? Sure would be nice to use this.

Creating a user with the ssh activation still isn’t implemented so it shouldn’t work right now.

Did you try with ncp as a user?

After doing that you should be able to login with the ncp user

Yes, I tried activating SSH with the NCP user. Everything seems to be working fine and I can login via SSH with the NCP user. It asks me to change the password again and terminates the connection. After logging in with the new password, I get the same “This account is currently not available” error and the SSH connection terminates.

Hmm, could you try creating a new user with ssh?

Something like this:

ssh ncp@nextcloudpi.local "useradd --create-home --home-dir /home/<username> --shell /bin/bash <username>; echo "<password>" | passwd --stdin <username>"

Replace <username> with the username you want to use and <password> with the password

Otherwise I guess you’ll have to use a previous image or wait until the user creation is implemented.

For a raspberry pi you can use the pi imager or userconf.txt file to create a user

https://www.raspberrypi.com/news/raspberry-pi-bullseye-update-april-2022/

Hi!
I have the same problem with an fresh installation ( using # curl -sSL https://raw.githubusercontent.com/nextcloud/nextcloudpi/master/install.sh | bash) on pi4 4GB 64bit OS Version.
NCP V1.51.0 NC 25.0.3 installed yesterday (2023-01-25).
When i use the NCP web-if to configure ssh i get this error-massage:

[ SSH ] (Thu Jan 26 06:33:12 CET 2023)
New password: Retype new password: passwd: password updated successfully
Password: chsh: PAM: Authentication failure
Enabled sudo for pi
Synchronizing state of ssh.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable ssh
SSH enabled

What can i do to fix it?

BR Michael