Unable to access NextCloud VM externally

vm

#1

Everything was working fine last night. I tried logging in this morning and got an error message on my iOS app suggesting there was an issue with the certificate. I tried accessing externally through the web app on safari and no luck either. It just showed the ‘safari cannot open the page because it could not estabslih a secure connection to the server’ blank page.

I’ve checked my DNS settings on my domain and they’re still set to my IP address (which hasnt changed). Checked my router settings and the MAC address is still locked on the correct internal IP address with ports 80 and 443 forwarded to it. So all the obvious things I could think of all correct.

I ran the sudo bash /var/scripts/activate-ssl.sh command yesterday and it all activated properly and worked fine for 24 hours but as of this morning can only be accessed internally.

I read somewhere that the ssl certificate needs to be regularly updated but I assumed this was every 30 days?

I tried running the ssl activation command again but that didn’t work.

Any ideas what might be causing it? Assuming it’ll be something simple.

Unfortunely not familiar with Linux so not sure what commands I can use to check scripts and ssl certificates etc. Is there a GUI that can be installed within NextCloud to handle all this sort of thing?

Thanks in advance
Sabri


#2

FWIW, the VM contains a cronjob that automatically updates the SSL certificates, but it might fail if DNS, external IP or something else changed since it was first generated.