Unable to access after enabling SSL. Please Help

After working with a http access, tried to access by https. Seems to work fine (certificates, so on), but now I get an error tryng to access:

“Internal Server Error
The server was unable to complete your request.
If this happens again, please send the technical details below to the server administrator.
More details can be found in the server log.”

Followed by some technical details:

  • Dirección remota:
  • ID de la solicitud: PVqh98SvK8kPnqqM0OMy

Nextcloud version : 15.0.5
Operating system and version : Ubuntu 16.04
Apache srv
PHP version: 7.0

I ca’n t access web page (only athentication step). If I try to autenticate vía web, I get that error.

The output of my config.php file:

<?php $CONFIG = array ( 'instanceid' => 'ocxtr4327wut', 'passwordsalt' => '...removed...', 'secret' => '...removed...', 'trusted_domains' => array ( 0 => '', 1 => 'cbarbudo.no-ip.org', ), 'datadirectory' => '/var/www/NCdata', 'dbtype' => 'mysql', 'version' => '', 'overwrite.cli.url' => '', 'dbname' => 'nextcloud', 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'oc_', 'mysql.utf8mb4' => true, 'dbuser' => '...removed...', 'dbpassword' => '...removed...', 'installed' => true, );

please change titel from ssh to ssl.

can you provide us with the message in the log, after switch back to http?

ah, and welcome to the forum :wink:

Logs I have, are older, like these ones:

{“reqId”:“3fLlKgpsUXJicGKwWgxp”,“level”:3,“time”:“2019-03-30T08:52:07+00:00”,“remoteAddr”:“”,“user”:“admin”,“app”:“PHP”,“method”:“POST”,“url”:"/index.php",“message”:“You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/html/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36”,“version”:“”}

I installed php-intl and do not have more messages here.
On the other hand, I disabled SSL to try to isolate problems and hace another issue. Do not access http (opened another ticket).

May be misconfigured chown or chmod y some directories. :-C

My nextcloud directory is /var/www/html
My Nextcloud DATA directory is /var/www/NCdata

If you have an issue with SSL, try looking at web-server error log.

For file access issue you can try:

# chown -R www-data:www-data /var/www/

If you are not using Debian or Ubuntu for your server remplace www-data with the right system user for your web-server.

I tried but I get this:

"El servidor no ha podido completar tu petición. (server could not complete request)

Detalles técnicos

  • ID de la solicitud: kjGeLu0c8Prq5P9Evmwa"

If I try to look for that ID on log there’s nothing relate to that ID on /var/www/html/data/access.log.

Any Idea.

Did you look at the error log, or only the access log?