UCS / Nextcloud - Apps missing in one specific environment

I am installing a vServer using an ISO image for univention corporate server (UCS). The installation works until the installation of Nextcloud from UCS App store.

The Nextcloud installation runs without error messages. But if I log into the Nextcloud Web interface there are no apps except dashboard, files, photos and activities. The menu for installing new apps is missing all the nice apps like calendar, mail, contacts, … you find in other UCS instances I installed on other platforms before.
On other platforms the installation log files for Nextcloud on UCS contain lines like

... calendar 4.4.3 enabled
... contacts 5.3.2 enabled

while they are missing on this platform.
Interesting that at the activities tab the filter categories für calendar, contacts and others exist!

Has anyone any idea what may have happened or where I can look for helpful informations?

During my tests i got this when I tried to manually load a app for Nextcloud:

cURL error 35: OpenSSL SSL_connect: Connection reset by peer in connection to github.com:443 (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://github.com/nextcloud-releases/calendar/releases/download/v4.4.3/calendar-v4.4.3.tar.gz
cURL error 28: Operation timed out after 120001 milliseconds with 0 bytes received (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://github.com/nextcloud-releases/contacts/releases/download/v5.3.2/contacts-v5.3.2.tar.gz

I also found that the vServer interface for the internet connection has a MTU of 1400 while all other interfaces including the docker0 interface have an MTU of 1500. 1500 ist the value I usually see on other platforms. Does this matter?

I changed the docker configuration. All interfaces used by docker showed a MTU of 1400.
Now for the Nexcloud apps mail, calendar and contacts installation worked without problems.

I tried to remove the Nextcloud app on the UCS and to reinstall it. The Nextcloud apps were still not installed. I couldn’t find out why.

I changed the provider. Now I have a MTU of 1500 on all interfaces and this problem disapeared.