Ubuntu 20.04 LTS & Nextcloud & Kemp Loadbalancer als Reverse Proxy HTTPS auf HTTP App Fehler

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 24.0.3.2
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25): ???
PHP version (eg, 7.4): ???

The issue you are facing:

'ipone App, Windows App: Fehler polling URL beginnt nicht mit HTTPS obwohl Anmelde URL mit HTTPS beginnt. Anmeldung ist nicht möglich.

Is this the first time you’ve seen this error? (Y/N):

Steps to replicate it:

  1. Kemp Loadmaster als Reverse Proxy
  2. Ubuntu mit Nextcloud installiert. Mit dem Browser kann ich mich anmelden, Apps verweigern die Anmeldung.
  3. Fehlermeldung: Die Polling-URL beginnt nicht mit HTTPS, obwohl die Anmelde-URL mit HTTPS beginnt. Die Anmeldung ist nicht möglich, da dies ein Sicherheitsproblem darstellen könnte. Bitte wenden Sie sich an Ihren Administrator.
  4. Ich suche eine Lösung wie ich diesen Fehler in den Apps beheben kann. HTTPs ist bis zum ReverseProxy installiert und läuft. Lediglich die Weiterleitung in einem gekapselten VLAN, per HTTP, blockiert nun die App nutzung. Wer kann helfen was es dazu benötigt. Bzw wie kann man diese Prüfung der Apps deaktivieren. Finde dieses Thema mühsam. Kaum Doku, habe alles durchprobiert was gepostet wurde. Komme nicht weiter… Auch mit snap hatte ich versuche gemacht. Dort konnte ich gewisse Fehler fixen welche im config.php nicht zu beheben waren. Ich wäre froh um jede Hilfe. Dank und Gruss.

The output of your Nextcloud log in Admin > Logging:

PASTE HERE

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

PASTE HERE

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

PASTE HERE


Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

PASTE HERE

Versuche mal in config/config.php:

'overwrite.cli.url' => 'https://nextcloud.mydomain.com',
'overwriteprotocol' => 'https',

Evtl. zusätzlich
'overwritehost' => 'nextcloud.mydomain.com',

Siehe z. B. auch diesen Issue.

1 Like

Vielen Dank für die Hilfe, ich war nun mehrere Abende dran, jegwelche Lösungsvorschläge zu versuchen. Da ich mit dem Kemp Reverse Proxy einsetze, fungiert dieser als SSL offloader, sprich ich muss nicht für jeden Server die SSL Zertifikate anpassen. Einmal Zentral und fertig. Nun das Problem vom Reverse Proxy zum Nextcloud Server wird über Port 80 (HTTP) ein forwarding hinterlegt. Es klappt alles soweit ausser die Apps auf den Mobiles und auf dem Desktop, diese machen eine SSL end zu end Prüfung, diese schlägt fehl. Die Fehlermeldung ist richtig. Da jedoch die Umgebung durch mehrere VLans getrennt, DMZ usw… Würde ich nextcloud gerne so betreiben. Ich kriege es nun nicht gebacken das diese Apps die SSL Prüfung nicht machen sollen… Ich finde dies recht mühsam, da nicht wirklich dokumentiert. Muss ich nun das Zertifikat auf dem ReverseProxy nun ein zweites Mal auf dem Nextcloud Server hinterlegen und hoffen das dies so greift mit der SSL/HTTPS Verbindung?! Bin da aktuell ein wenig ratlos… Vielen Dank für ein paar Kreative Ideen… Am liebsten wären mir neue Apps die die SSL Prüfung nicht ausführen …

Ja dies habe ich schon längst versucht, ohne Erfolg, auch jede IP Adresse eingetragen, welche involviert ist. Eigene Domain, mit Subdomain. Alles was mir einfiel. Nichts half. Vom beschriebenen Fehler her auch klar warum. Es wird eine SSL/HTTPS Verbindung bis zum Nextcloud Server hin verlangt. Überlege mir nun ob ich mir den Nextcloudserver nochmals neu bauen soll. Diesmal Manuell und nicht aus dem Ubuntu ISO mit Nextcloud Option, welche alles vollautomatisch aufsetzt…

über nextcloud.occ gibt es keinen Weg? Diese Einträge zu machen? Meine das die config.php nicht wirklich greift.

Wenn du Nextcloud direkt vom Ubuntu Installer aus installiert hast, nutzt du das Snap Package. Hier ein Link zur offiziellen Doku: Putting the snap behind a reverse proxy · nextcloud-snap/nextcloud-snap Wiki · GitHub

Doch. Hier ein paar Beispiele aus obigem Link:

$ sudo nextcloud.occ config:system:set overwritehost --value="example.com:81"
$ nextcloud.occ config:system:set overwritehost --value="mydomain.com"
$ nextcloud.occ config:system:set overwriteprotocol --value="https"
$ nextcloud.occ config:system:set overwritewebroot --value="/mycustompath"
$ nextcloud.occ config:system:set overwrite.cli.url --value="https://mydomain.com/mycustompath"

1000 Dank für die Hilfe, so läufts, sprich die config.php hat gar nicht gebracht, es muss tatsächlich über snap und den *.occ Weg die Konfig angepasst werden. Danke nochmals.

Frage welche Installationsart hast du gewählt? Es gibt ja zigg verschiedene Ansätze, auch als Container…

Gern geschehen. :slight_smile:

Ich habe meine Nextcloud manuell installiert, basierend auf dieser Anleitung von Carsten Rieger: Nextcloud Installationsanleitung Apache2 - Carsten Rieger IT-Services