Ubuntu 18.04 and next cloud

hello,

i am trying to install NextCloud . I insalled ubuntu 18.04.
What i do is the following:
i go to
https://docs.nextcloud.com/server/13/admin_manual/installation/source_installation.html#ubuntu-installation-label

and choose the Example installation on Ubuntu 16.04 LTS server

sudo snap install nextcloud

after that, i try to download the nextcloud throughn this:
wget https://download.nextcloud.com/server/releases/nextcloud-x.y.z.tar.bz2.asc
wget https://nextcloud.com/nextcloud.asc
gpg --import nextcloud.asc
gpg --verify nextcloud-x.y.z.tar.bz2.asc nextcloud-x.y.z.tar.bz2

i change the -x.y.z. through -13.0.4.

but when i am entering the gpg commands, at the gpg --import nextcloud.asc i get an unchanged:1 notification and when entering gpg --verify , i get can’t open signed sdata and can’t hash datafiles erros. anyone who can explain to me what i am missing?

thank you?

never did a snap installation. but after

nextcloud installation is ready. no need to download the source.

many thanks for the fast repply. So after installing through Snap, i need to continue with the Apache Web server configuration part? if so, how do i create the file nextcloud.conf with my own filepaths and how do i know what my own filepaths are after installing rhotugh Snap?

no. the services (apache, php, redis) are already configured.

you only have to create a user/password

sudo nextcloud.manual-install andre PaSsWord#123

and add your server url to the trusted domains

sudo nextcloud.occ config:system:set trusted_domains 1 --value=example.com

and turning on ssl would be a very good idea if you want to access your nextcloud through the internet.

I wouldn’t use the snap-stuff on a real server with enough resources. The image is optimized for small ARM-devices and the configuration can’t be changed easily.

it is just for testing purposes

works also for ubuntu 18.

1 Like

why shouldnt i use the snap-stuff?

depends an your tests.
the ansible playbook offers a “real” installation. with latest packages.
(and in the devel branch also collabora office.)

It depends on your use case and hardware:

i used your tutorial from Github(the link proved there isnt working anymore btw) to install nextcloud on my Ubuntu server. And it works without any errors. So this Ansible Playbook installed Newxtcloud, nginx,php,mariadb and redis?
But because of installing nextcloud at Ubuntu server, how should i conenct and configure? Can i connect from a client to the nextcloud?(tried that btw, but that doesnt work) . I changed the fqdn to nextcloudtest.test.local in the inventory btw.

thanks!!!

you should be able to access nextcloud via webbrowser. https://ip-of-your-server/ (or any dns name of your server)

Ok, there it goes wrong. I can ping from my ubuntu desktop to the ubuntu server, but the website is not accessible from my desktop . My first thought is that some daemons aint working, how should i troubleshoot this?

on the server cli enter
sudo systemctl status nginx
sudo systemctl status php7.2-fpm
sudo systemctl status mysql
sudo systemctl status redis

each output should have line
Active: active (running)

and
sudo ufw status
would be helpfull

many thanks(again) for the reply. the four give all a green status active, sudo ufw status gives me an inactive

btw, am getting the following error when trying to connect to nextcloud:
Secure Connection Failed

The connection to 192.168.206.131 was interrupted while the page was loading.

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

looks like you are using a selfsigned certificate.
normally your browser would offer you to accept that.
which browser you are using?

mozilla, the defaultone in ubuntu desktop. Dit change anything with certificates, tried this:
https://www.zubairalexander.com/blog/how-to-resolve-the-secure-connection-failed-error-in-firefox/
but that didnt help

i guess that’s the nginx config.
you change the following line in /etc/nginx/headers.conf

#add_header Strict-Transport-Security "max-age=63072000; includeSubdomains; preload"; add_header Strict-Transport-Security "max-age=63072000; includeSubdomains";

adding that didnt work. noticed the headers.conf was completely empty. is that correct?