Two versions of Nextcloud on one system - Zorin 12 (Ubuntu 16.04)

Nextcloud version (eg, 10.0.2): 12.0.0
Operating system and version (eg, Ubuntu 16.04): 16.04 Zorin 12
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.18
PHP version (eg, 5.6): 7.0.18
Is this the first time you’ve seen this error?: Yes

Can you reliably replicate it? (If so, please outline steps): Yes

Hi all,

I need your help and just when I thought m8y system is secure up and running, then now I have this strange and mind boggling issue. I have my V12.0.0 up and running and set up correctly with SSL and got A+ grading for my Nextcloud / Apache. Now I have just noticed that if I access from my local network with my local IP address as it is, then I will be connected to 11.0.3 version of Nextcloud and asked me to register a user (in this case I did, test123). But if I access via https:// then it will take me to version 12.0.0 which is what I have set up and installed for (using DDNS address also points to version 12.0.0).

So I think the issues and steps to cause this happen were as follows -

  1. I installed Nextcloud 11.0.3 some time ago but DIDN’T complete the setup (could be using snap command as per official website indicated)

  2. Then I downloaded version 12.0.0 via the website (other online tutorial and not using SNAP) and installed it and worked perfectly (also changed external file storage and etc). so this is all up and running.

  3. I have now tried to upload a file and it went through successfully? but when I check under /var/www and I cannot find the name testing and I have further created another user rollo but I also cannot seem to find this user’s data …
    so now I am completely puzzled! (usually fall under /media/external HDD /nextcloud data/data or /www/var/ or /var/www/nextcloud as default.

  4. Now if I do snap info nextcloud, this is what I get -

name: nextcloud
summary: "Nextcloud Server"
publisher: nextcloud
contact: https://github.com/nextcloud/nextcloud-snap
description: |
Access & share your files, calendars, contacts, mail & more from any device,
on your terms.
commands:

  • nextcloud.disable-https
  • nextcloud.enable-https
  • nextcloud.manual-install
  • nextcloud.mysql-client
  • nextcloud.mysqldump
  • nextcloud.occ
    tracking: stable
    installed: 11.0.3snap6 (1982) 187MB -
    refreshed: 2017-07-05 02:48:12 +0200 SAST
    channels:
    latest/stable: 11.0.3snap6 (1982) 187MB -
    latest/candidate: 11.0.3snap6 (1982) 187MB -
    latest/beta: 11.0.3snap6 (1980) 187MB -
    latest/edge: master-2017-07-10 (2061) 189MB -
    11/edge: 11-2017-07-10 (2060) 189MB -
    12/edge: 12-2017-07-10 (2059) 189MB -

so my next question is… can I SAFEY use snap remove nextcloud seeing it is showing 11.0.3 version and not 12.0.0 version or … is it going to cause problems after I run the command and it will somehow impact my 12.0.0 system? My 12.0.0 has set up in such way that you cannot access 11.0.3 externally (just tested) but it CAN point to 11.0.3 internally. Any suggestions and solutions are welcome and I actually want to remove 11.0.3 off my system as I don’t use it at all.

Thanks and much appreciate your input in advance!

Hi all, anyone has a suggestion on this issue and maybe a solution? Thanks.

Looks like you could remove snap. However, isn’t this the ideal moment to make a backup and test your backup and restore procedure? I wouldn’t do such things without a full backup, much to easy to do something wrong.

Hi @tflidd

thanks for the heads up! My data are all sitting at external drive so I doubt it will affect it. But for all the system settings, yes you are ABSOLUTELY correct! Let me try to back up first before I use snap to remove the older version. Thanks for the heads up!