Two problems with Onlyoffice (+ Community Document Server) on NC22

Nextcloud version (eg, 20.0.5):
Operating system and version (eg, Ubuntu 20.04): Ubuntu 18.04 LTS 64bit
Apache or nginx version (eg, Apache 2.4.25): Apache: httpd 2.4.29-1ubuntu4.16
PHP version (eg, 7.4): PHP8: 8.0.7-ubuntu.18.04.210604.0824

The issue you are facing:
Since I updated to NC22 I have problems with OnlyOffice. I have the Community Document Server installed.

Every time I try to open a document while I am logged it (don’t matter if I open it directly in the cloud or via public link), I get the message that says only 20 connections are supported.
The problem is that the connection limit never has been reached and even can’t be reached directly after a server reboot.

An another indicator and also another problem/bug is, that I can open public links without beeing logged in (e.g. in a private window in Firefox) and any connection limit message. But ONLY, as long the app Deck is not enabled. As soo as the App Deck is enabled I get an internal server error on accessing public document links. I already created an issue for that here. It’s maybe missplaced and should be re-created on the Deck repo, will do that soon.

However, there are no errors, infos or even debug notes in the info that I can see through the web interface in Settings->Protocolling (with Debug enabled)

I have another productive NC22 instance with nearly the same apps and configs. It works well there. It works also well on the one test instance I created. Don’t know why I have this two problems with instance.

Hopefully someone can help me solving the problems. They are annoing and i want (or need) to fix them as soon as possible.


Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Update to NC22 and all Apps
  2. Enable the App Deck
  3. Login to Nextclodu instance
  4. (Create and) open a document
  5. Create a public link for that document and try open it in the same browser in another tab.
  6. Try open the public link in a private browser window.
  7. Disable the App Deck
  8. Repeat step 4 to 6

The output of your Nextcloud log in Admin > Logging:
Link: Pilzcloud
Passwort: nNSeN3IZfLzj7UFHZqQC

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'maintenance' => false,
  'instanceid' => '-',
  'passwordsalt' => '-',
  'secret' => '-',
  'trusted_domains' => 
  array (
    0 => '',
    1 => '',
    2 => 'localhost',
    3 => '',
    4 => '',
  'datadirectory' => '/var/www/vhosts/',
  'tempdirectory' => '/var/www/vhosts/',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'pilzinsel64_pilzcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '-',
  'dbpassword' => '-',
  'installed' => true,
  'app_install_overwrite' => 
  array (
    0 => 'occweb',
    1 => 'dropit',
    2 => 'files_external_onedrive',
    3 => 'ocdownloader',
    4 => 'files_readmemd',
    5 => 'joplin',
    6 => 'workflow_script',
    7 => 'twofactor_email',
    8 => 'files_markdown',
    9 => 'files_automatedtagging',
    10 => 'files_accesscontrol',
    11 => 'external',
    12 => 'files_downloadactivity',
    13 => 'files_trackdownloads',
    14 => 'terms_of_service',
    15 => 'issuetemplate',
    16 => 'deck',
    17 => 'whiteboard',
    18 => 'announcementcenter',
    19 => 'documentserver_community',
    20 => 'extract',
    21 => 'files_3d',
    22 => 'hsts',
    23 => 'files_texteditor',
    24 => 'drop_account',
    25 => 'side_menu',
    26 => 'apporder',
    27 => 'groupfolders',
    28 => 'files_linkeditor',
    29 => 'login_notes',
    30 => 'onlyoffice',
    31 => 'talk_simple_poll',
    32 => 'talk_matterbridge',
    33 => 'twofactor_admin',
    34 => 'twofactor_gateway',
    35 => 'twofactor_nextcloud_notification',
    36 => 'tasks',
    37 => 'files_retention',
    38 => 'hidesidebars',
    39 => 'forms',
    40 => 'workflow_pdf_converter',
  'theme' => '',
  'loglevel' => 0,
  'twofactor_enforced' => 'false',
  'twofactor_enforced_groups' => 
  array (
  'twofactor_enforced_excluded_groups' => 
  array (
    0 => 'Bot',
  'filelocking.enabled' => true,
  '' => 'stable',
  'activity_use_cached_mountpoints' => true,
  'remember_login_cookie_lifetime' => 15552000,
  'htaccess.RewriteBase' => '/',
  'htaccess.IgnoreFrontController' => true,
  'simpleSignUpLink.shown' => false,
  'filelocking.ttl' => 300,
  'blacklisted_files' => 
  array (
  'sharing.enable_share_accept' => false,
  'overwriteprotocol' => 'https',
  'skeletondirectory' => '',
  'share_folder' => '/Shares',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => '-',
  'mail_domain' => '-',
  'mail_smtpauth' => 1,
  'mail_smtphost' => '-',
  'mail_smtpname' => '-',
  'mail_smtppassword' => '-',
  'ldapIgnoreNamingRules' => false,
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'mail_smtpport' => '465',
  'mail_smtpsecure' => 'ssl',
  'default_locale' => 'de',
  'trusted_proxies' => 
  array (
    0 => '',
    1 => '',
    2 => '::1',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '',
    'port' => 6379,
  'default_phone_region' => 'DE',

Hi @Pilzinsel64 this is strange, nextcloud nextcloud considers some files of your installled apps as extra files so they are not used …
usually , to remove extra files message you have to delete these files but those are files used by applications …
try to reinstall the apps.

Hi. Thanks for your answer @Mageunic
Where can you see the list of extra files?

Btw, I already treid to re-installed the apps, I even tried to disable any own installed apps. Lastly I also tried to remove the “apps” folder and put there the apps folder of the “”, re-installed onlyoffice and community document server, but the connection problem still happens. And as soon as I install Deck, the internal server error happens again.

So, additional files in the apps folder shouldn’t be a problem.

I also made an integrity check right now (because he still noted the already removed temporary app folder backup) and everything seems to be fine now:

@Pilzinsel64 the extra files list was inside the link you send :

Array ( [core] => Array ( [EXTRA_FILE] => Array ( [] => Array ( [expected] => [current] => 5fc7f8419c2d1f906f0e8f942766c15807d77f81965cedf3ad1dc8aefd9bcf9da98d00857fce0ba89a94088ce31246ae37bcc34613088bd2367a46dbfdaa0b78 ) …

have you some logs about your errors inside nextcloud logging menu ?

Ah, the “” folder was the temporary backup folder that I already have remove. Sorry for confusing.

No, there aren’t any logs (except the error if Deck is enabled and access public link without beeing logged in). No error, info or debug info. Nothing. I tested with Live update enabled, but opening the document on the different ways described above doesn’t create an entry.

I guess OnlyOffice fails for whatever reason and OnlyOffice don’t know what’s wrong. The result is a wrong message that says the connection limit has been reached.

But the question for me is, why it happens only for this instance and only for me? An incompatible app can’t be the reason, I already tried without any additional apps installed.

I really would like to completlely remove the onlyoffice and documentserver_community app with all the settings and database tables and entries but that would make a lot work. I would try as last option, if could be other options.

@Pilzinsel64, I think there is no other solution than to remove all the elements of document server otherwise you can install an onlyoffice server on the same server or apartment. I use an onlyoffice server on the same machine and not the nextcloud application (Community document server app)

there is 4 tables inside database :

Sadly that didn’t work. And also I falsely removed “oc_onlyoffice_filekey” too, now I don’t get the app working again.

Why I use the App of Nextcloud for the document server is because I don’t need more, even if the performance isn’t as good as directly installed. It’s very simple to install and administrate. Overall I simple can increase the connection limit and re-enable mobile edit.
I already tried the official docker image btw, but has no luck, because the hoster of my VServer has some mystic configurations that makes it impossible to use docker container, even if its allowed. And revert them has no effect for whatever reason.

However, A.t.m. I’m doing a roll back of my server to a state of before the upgrade from NC21 to 22 and try after I try to upgrade again. Let’s see if it works this time. I will notify you as soon as I can test and upgrade to NC22 again.

Thank you for the help till now, let’s see if the restore and re-upgrade helps. Will let you know ASAP. :slightly_smiling_face:

1 Like

Alright, the rollback is done and I’m on NC 21.0.3 again.

But as I can see the problem still exists, before and after updating the apps. Will not upgrade to NC22 until the problem is fixed. But saldy I really have no clue what’s wrong here… Maybe the bug alreads started with the update to NC 21.0.3? :confused:

I updated Deck to v1.4.3 right now and OnlyOffice works again. Let me upgrade to NC22 and see what happens. Will notfiy you soon.

Upgraded to NC22. The Deck app updated to v1.5.0.
Right now, OnlyOffice works when logged in. Let’s see if the time till tomorrow will change that again.
But what still not work is accessing public links without beeing logged in. It still throws the internal server error of Nextcloud.

1 Like

Alright, the problems still exist. Really don’t know what I can do anymore … :pensive:

However, the problem seems to be known now and I got a temporary solution until the connection limit bug has been fixed: