Two-factor auth providers failed to load

Nextcloud version (eg, 20.0.5): 24.0.5
Operating system and version (eg, Ubuntu 20.04): Debian 11
Apache or nginx version (eg, Apache 2.4.25): 1.18.0
PHP version (eg, 7.4): 8.1.10

The issue you are facing:
only one error message in the log
the two providers have not been installed for a long time, how can I remove them completely?

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. login

The output of your Nextcloud log in Admin > Logging:

{"reqId":"E2wNSnT42xWmumF2EZvC","level":3,"time":"2022-09-22T10:29:39+02:00","remoteAddr":"192.168.100.11","user":"Tealk","app":"core","method":"POST","url":"/login/challenge/totp","message":"2 two-factor auth providers failed to load","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:105.0) Gecko/20100101 Firefox/105.0","version":"24.0.5.1","data":{"app":"core"},"id":"632c1d82a1ce6"}
{"reqId":"E2wNSnT42xWmumF2EZvC","level":3,"time":"2022-09-22T10:29:39+02:00","remoteAddr":"192.168.100.11","user":"Tealk","app":"core","method":"POST","url":"/login/challenge/totp","message":"two-factor auth provider 'yubiotp' failed to load","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:105.0) Gecko/20100101 Firefox/105.0","version":"24.0.5.1","data":{"app":"core"},"id":"632c1d82a1cef"}
{"reqId":"E2wNSnT42xWmumF2EZvC","level":3,"time":"2022-09-22T10:29:39+02:00","remoteAddr":"192.168.100.11","user":"Tealk","app":"core","method":"POST","url":"/login/challenge/totp","message":"two-factor auth provider 'u2f' failed to load","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:105.0) Gecko/20100101 Firefox/105.0","version":"24.0.5.1","data":{"app":"core"},"id":"632c1d82a1cf6"}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

{
    "system": {
        "instanceid": "***REMOVED SENSITIVE VALUE***",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
            "rollenspiel.cloud",
            "192.168.100.11",
            "localhost"
        ],
        "datadirectory": "***REMOVED SENSITIVE VALUE***",
        "overwrite.cli.url": "https:\/\/rollenspiel.cloud",
        "overwriteprotocol": "https",
        "htaccess.RewriteBase": "\/",
        "dbtype": "pgsql",
        "version": "24.0.5.1",
        "dbname": "***REMOVED SENSITIVE VALUE***",
        "dbhost": "***REMOVED SENSITIVE VALUE***",
        "dbport": "",
        "dbtableprefix": "oc_",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "mysql.utf8mb4": true,
        "installed": true,
        "maintenance": false,
        "default_language": "de",
        "default_locale": "de",
        "default_phone_region": "DE",
        "allow_user_to_change_display_name": true,
        "knowledgebaseenabled": true,
        "theme": "",
        "defaultapp": "apporder",
        "skeletondirectory": "\/mnt\/hdd\/skeleton",
        "trashbin_retention_obligation": "120, auto",
        "versions_retention_obligation": "120, auto",
        "appcodechecker": true,
        "updatechecker": true,
        "updater.release.channel": "stable",
        "check_for_working_webdav": true,
        "maintenance_window_start": 3,
        "loglevel": 2,
        "logdateformat": "d.m.Y H:i:s",
        "logtimezone": "Europe\/Berlin",
        "log_rotate_size": 10485760,
        "mail_smtpmode": "smtp",
        "mail_smtpauthtype": "PLAIN",
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpsecure": "ssl",
        "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpport": "465",
        "mail_smtpauth": 1,
        "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
        "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
        "enable_previews": true,
        "preview_max_x": 2048,
        "preview_max_y": 2048,
        "preview_max_filesize_image": 50,
        "preview_max_scale_factor": 10,
        "data-fingerprint": "d76fcffe3970dd2910ea5d733e3ed673",
        "memcache.local": "\\OC\\Memcache\\APCu",
        "memcache.distributed": "\\OC\\Memcache\\APCu",
        "memcache.locking": "\\OC\\Memcache\\APCu",
        "redis": {
            "host": "***REMOVED SENSITIVE VALUE***",
            "port": 6379,
            "dbindex": 1,
            "timeout": 1.5
        },
        "filelocking.enabled": "true",
        "twofactor_enforced": false,
        "twofactor_enforced_groups": [
            "admin"
        ],
        "twofactor_enforced_excluded_groups": [],
        "mail_sendmailmode": "smtp",
        "migrate_guest_user_data": true,
        "remove_guest_account_on_conversion": true,
        "keep_users_without_login": "no",
        "trusted_proxies": "***REMOVED SENSITIVE VALUE***",
        "app_install_overwrite": [
            "uppush",
            "gpgmailer"
        ]
    }
}

App list

Enabled:
  - accessibility: 1.10.0
  - activity: 2.16.0
  - admin_audit: 1.14.0
  - appointments: 1.12.8
  - apporder: 0.15.0
  - approval: 1.0.10
  - breezedark: 24.0.2
  - calendar: 3.5.0
  - circles: 24.0.1
  - cloud_federation_api: 1.7.0
  - collectives: 1.5.0
  - comments: 1.14.0
  - contacts: 4.2.1
  - dashboard: 7.4.0
  - dav: 1.22.0
  - deck: 1.7.1
  - drawio: 1.0.3
  - drop_account: 2.1.0
  - event_update_notification: 1.5.0
  - federatedfilesharing: 1.14.0
  - federation: 1.14.0
  - files: 1.19.0
  - files_downloadactivity: 1.13.0
  - files_linkeditor: 1.1.11
  - files_lock: 24.0.1
  - files_markdown: 2.3.6
  - files_pdfviewer: 2.5.0
  - files_rightclick: 1.3.0
  - files_sharing: 1.16.2
  - files_trashbin: 1.14.0
  - files_versions: 1.17.0
  - files_videoplayer: 1.13.0
  - fileslibreofficeedit: 1.1.0
  - firstrunwizard: 2.13.0
  - forms: 2.5.1
  - gpgmailer: 0.0.4
  - gpoddersync: 3.4.0
  - groupfolders: 12.0.1
  - guests: 2.2.0
  - jitsi: 0.15.0
  - logreader: 2.9.0
  - lookup_server_connector: 1.12.0
  - mail: 1.13.8
  - maps: 0.2.1
  - metadata: 0.16.0
  - nextcloud_announcements: 1.13.0
  - notes: 4.5.1
  - notifications: 2.12.1
  - oauth2: 1.12.0
  - password_policy: 1.14.0
  - passwords: 2022.9.20
  - photos: 1.6.0
  - polls: 3.8.1
  - privacy: 1.8.0
  - provisioning_api: 1.14.0
  - quota_warning: 1.14.0
  - registration: 1.5.0
  - richdocuments: 6.2.0
  - serverinfo: 1.14.0
  - settings: 1.6.0
  - sharebymail: 1.14.0
  - side_menu: 2.5.1
  - socialsharing_email: 2.5.0
  - spreed: 14.0.5
  - survey_client: 1.12.0
  - systemtags: 1.14.0
  - tasks: 0.14.4
  - text: 3.5.1
  - theming: 1.15.0
  - theming_customcss: 1.12.0
  - twofactor_backupcodes: 1.13.0
  - twofactor_email: 2.7.0
  - twofactor_nextcloud_notification: 3.4.0
  - twofactor_totp: 6.4.0
  - twofactor_webauthn: 0.3.2
  - updatenotification: 1.14.0
  - user_migration: 1.1.0
  - user_retention: 1.7.0
  - user_status: 1.4.0
  - viewer: 1.8.0
  - workflowengine: 2.6.0
Disabled:
  - contactsinteraction: 1.3.0
  - encryption
  - files_external
  - recommendations: 1.3.0
  - support: 1.5.0
  - uppush: 1.1.1
  - user_ldap
  - weather_status: 1.0.0

The output of your Apache/nginx/system log in /var/log/____:

nothing relevant

I tried to turn it off with these 2 commands

php occ twofactorauth:cleanup yubiotp
php occ twofactorauth:cleanup u2f

so far i have not received any further message

The reason for that messages might be that both apps are not supported anymore by Nextcloud 24.x:

Two Factor Yubikey - Apps - App Store - Nextcloud → Latest version: NC 15.x
⚠️ Deprecated ⚠️ Two-Factor U2F - Apps - App Store - Nextcloud → Latest version: NC 23.x

I am only surprised because the two apps were already deleted for a long time