Trying to install an App to nextcloud

[details=“Support intro”]

snippet:

When I try to install an app to my nextcloud instance this problem occurs```
Nextcloud version _28.0.2
Operating system and version _(eg, Ubuntu 20.04)_: Ubuntu 22.04
Apache or nginx version _(eg, Apache 2.4.25)_:  `
PHP version _(eg, 7.4)_: 8.2.15

The issue you are facing:
[settings] Fehler: could not enable apps
	POST /index.phpapps/enable
	von 91.44.135.36 von admin um 05.02.2024, 22:36:25



Is this the first time you've seen this error? _(Y/N)_: Y

Steps to replicate it:

1. Try to install an App within nextcloud
2. 
3. 

The output of your Nextcloud log in **Admin > Logging**:

[settings] Fehler: could not enable apps
POST /index.phpapps/enable
von 91.44.135.36 von admin um 05.02.2024, 22:36:25


The output of your config.php file in `/path/to/nextcloud` (make sure you remove any identifiable information!):

on demand, because I am afraid it won’t help


The output of your Apache/nginx/system log in `/var/log/____`:

[Mon Feb 05 22:20:13.986814 2024] [mpm_prefork:notice] [pid 200] AH00163: Apache/2.4.52 (Ubuntu) configured – resuming normal operations
[Mon Feb 05 22:20:13.986920 2024] [core:notice] [pid 200] AH00094: Command line: ‘/usr/sbin/apache2’


PASTE HERE

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

{“reqId”:“VAEQXjbZ9HrGfitdl6dl”,“level”:3,“time”:“2024-02-05T22:36:25+01:00”,“remoteAddr”:“91.44.135.36”,“user”:“admin”,“app”:“settings”,“method”:“POST”,“url”:“/index.phpapps/enable”,“message”:“could not enable apps”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:123.0) Gecko/20100101 Firefox/123.0”,“version”:“28.0.2.5”,“exception”:{“Exception”:“GuzzleHttp\Exception\ConnectException”,“Message”:“cURL error 28: Connection timed out after 120000 milliseconds (see libcurl - Error Codes) for https://github.com/ariselseng/camerarawpreviews/releases/download/v0.8.4/camerarawpreviews_nextcloud.tar.gz",“Code”:0,“Trace”:[{“file”:“/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php”,“line”:158,“function”:“createRejection”,“class”:“GuzzleHttp\\Handler\\CurlFactory”,“type”:“::”,“args”:["*** sensitive parameters replaced “]},{“file”:”/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php",“line”:110,“function”:“finishError”,“class”:“GuzzleHttp\Handler\CurlFactory”,“type”:“::”},{“file”:“/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlHandler.php”,“line”:47,“function”:“finish”,“class”:“GuzzleHttp\Handler\CurlFactory”,“type”:“::”},{“file”:“/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Middleware.php”,“line”:137,“function”:“__invoke”,“class”:“GuzzleHttp\Handler\CurlHandler”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/Http/Client/DnsPinMiddleware.php”,“line”:161,“function”:“GuzzleHttp\{closure}”,“class”:“GuzzleHttp\Middleware”,“type”:“::”,“args”:[" sensitive parameters replaced “]},{“file”:”/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/PrepareBodyMiddleware.php",“line”:35,“function”:“OC\Http\Client\{closure}”,“class”:“OC\Http\Client\DnsPinMiddleware”,“type”:“->”,“args”:[" sensitive parameters replaced “]},{“file”:”/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Middleware.php",“line”:31,“function”:“__invoke”,“class”:“GuzzleHttp\PrepareBodyMiddleware”,“type”:“->”},{“file”:“/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/RedirectMiddleware.php”,“line”:71,“function”:“GuzzleHttp\{closure}”,“class”:“GuzzleHttp\Middleware”,“type”:“::”,“args”:[" sensitive parameters replaced “]},{“file”:”/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Middleware.php",“line”:63,“function”:“__invoke”,“class”:“GuzzleHttp\RedirectMiddleware”,“type”:“->”},{“file”:“/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/HandlerStack.php”,“line”:75,“function”:“GuzzleHttp\{closure}”,“class”:“GuzzleHttp\Middleware”,“type”:“::”,“args”:[" sensitive parameters replaced “]},{“file”:”/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php",“line”:331,“function”:“__invoke”,“class”:“GuzzleHttp\HandlerStack”,“type”:“->”},{“file”:“/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php”,“line”:168,“function”:“transfer”,“class”:“GuzzleHttp\Client”,“type”:“->”},{“file”:“/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php”,“line”:187,“function”:“requestAsync”,“class”:“GuzzleHttp\Client”,“type”:“->”,“args”:[" sensitive parameters replaced ***”]},{“file”:“/var/www/html/nextcloud/lib/private/Http/Client/Client.php”,“line”:230,“function”:“request”,“class”:“GuzzleHttp\Client”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/Installer.php”,“line”:297,“function”:“get”,“class”:“OC\Http\Client\Client”,“type”:“->”},{“file”:“/var/www/html/nextcloud/apps/settings/lib/Controller/AppSettingsController.php”,“line”:451,“function”:“downloadApp”,“class”:“OC\Installer”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/AppFramework/Http/Dispatcher.php”,“line”:230,“function”:“enableApps”,“class”:“OCA\Settings\Controller\AppSettingsController”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/AppFramework/Http/Dispatcher.php”,“line”:137,“function”:“executeController”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/AppFramework/App.php”,“line”:184,“function”:“dispatch”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:“->”},{“file”:“/var/www/html/nextcloud/lib/private/Route/Router.php”,“line”:315,“function”:“main”,“class”:“OC\AppFramework\App”,“type”:“::”},{“file”:“/var/www/html/nextcloud/lib/base.php”,“line”:1069,“function”:“match”,“class”:“OC\Route\Router”,“type”:“->”},{“file”:“/var/www/html/nextcloud/index.php”,“line”:39,“function”:“handleRequest”,“class”:“OC”,“type”:“::”}],“File”:“/var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php”,“Line”:210,“message”:“could not enable apps”,“exception”:{},“CustomMessage”:“could not enable apps”}}

You have a configuration problem somewhere. Your URLs are not being generated correctly.

  • What install method did you use to install Nextcloud Server?
  • Please provide the output of occ config:list system

Are you having any other problems with Nextcloud or just unable to enable apps?

It is behind a nginx proxy manager.
Thank you very much.
I had to replace the overwrite cli url with the external address.
Now it works.
Thank you again!