Trying to copy into external hhd imported in NC

I have snap NC and when I try to copy a folder to an external hdd from nextcloud web interface I get this error inside logs

copy(): Write of 258820 bytes failed with errno=30 Read-only file system at /snap/nextcloud/29247/htdocs/lib/private/Files/Storage/Local.php#355

Some suggestions?

And if I try to copy with cp Linux command (after run ‘snap stop nextcloud’ ) from a folder inside data NC folder to the same hdd, gives error of read only filesystem

The hdd is new, recently bought and formatted to ext4

give errors also with rclone. strange

I just wipe the new disk with mkfs.ext4 but after copying from web page of NC and after gave same error of ‘impossible copy folder name’, the disk goes to readonly and it shows in ‘sudo mount’ as
/dev/sdb1 on /media/myDisk type ext4 (ro,relatime)

I have this error in NC log:
Error: copy(): Write of 151828 bytes failed with errno=30 Read-only file system at /snap/nextcloud/29247/htdocs/lib/private/Files/Storage/Local.php#355

Solved: Was a problem of not enough power on hdd. Raspberry handle max 1.2 A. With a ssd and a hdd it goes over that quantity.