Trying to access Nextcloud server opens router management login

Hi!

I’m a new Nextcloud user. I installed it on a fresh Ubuntu machine using Snap.
It works fine inside my local network but I’m really stuck trying to access it from the public internet.
I registered to Noip.com in order to get a DDNS address for the machine.
My router is Huawei HG635 and it doesn’t support Noip.com in the DDNS settings, so instead of configuring it in the router I installed the software for Noip.com in the computer.

The problem is that when I type in the DDNS address I will get redirected to the router management panel. I have been googling around like crazy and these are some of the things I have tried:

  1. Change the port of the management software -Didn’t find a way of doing this in the HG635
  2. Try bridging for the LAN port connected to the machine. -After turning on bridging the computer could not connect at all anymore.
  3. Do port forwarding in the router. -I’m not sure how to properly set this up in the HG635. Here is what I tried (for some reason image upload didn’t work for me so I’m writing the parameters as text):
    Mapping name: nxt
    Application: WebServer(HTTP)
    Internal host: ubuntuserver-PRO-H61-IM-Ethernet

There is also the option to create a new rule, but I’m not sure what values I should insert into these fields:
External port: ___ ~ ___
Internal port: ___ ~ ___
Protocol: (possible options are TCP, UDP and TCP/UDP)

If I try to access the DDNS address from an outside connection (not my home network) then it will actually load Nextcloud login.
But it won’t really be usable if I can only access Nextcloud from outside my home network…

I’m quite new to this networking stuff and really stuck at the moment. Any help would be greatly appreciated!

just use the local IP address when logging in from home. You can setup these addresses in /nextcloud/config/config.php

1 => ‘localhost’,
2 => ‘your local IP’,
3 => ‘the ddns address’,

Give this a try

Thank you so much for helping!

I added what you suggested and rebooted, but unfortunately it still opens the router web manager login. Just to be clear ‘your local ip’ should be the address of a second computer in the network right, not the IP of the Ubuntu server machine?

Oh it seems like I indeed needed to put in the server machine’s IP in the list. Now I’m able to access Nextcloud by typing in the server’s IP address on one of my other computers. Thanks again for helping!