Trusted domain error remains after domain added


#1

Nextcloud version 15.0.0.10
Operating system Ubuntu 18.04 bionic beaver server
Apache/2.4.29 (Ubuntu)
PHP 7.2.10-0ubuntu0.18.04.1
mysql Ver 15.1 Distrib 10.1.34-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2

Hi all,
i did some checking to my problem online but could not find much on it. i get an trusted domain error when trying to call my nextcloud via local IP address as shown below excerpt from the log file. Having found that i did input the corresponding IP into the config.php but still no change. I can get through from my sample.domain.com though. Does anyone have an idea on how to solve this?

I might have some special network setting, which maybe contributes to the problem using cascaded routers. router 1 connected WAN to internet, LAN to router 2 and 3. Router 2 LAN has the nextcloud server, from Router 3 LAN I try to access nextcloud on R2. Routes seem to be in place alright, since i can SSH into the server and actually get the trusted domain error from nextcloud server.
Appreciate any help, thx : )
Knut

The output of my admin log:

Trusted domain error. "192.168.10.30" tried to access using "192.168.20.91" as host.

The config.php conatins the following under /var/www/nextcloud/config :

  'trusted_domains' => 
  array (
    0 => '192.168.30.254',
    1 => 'sample.domain.com',
    2 => '192.168.10.30',
  ),

#2

Did you restart your webserver after making the changes?


#3

I did even though other changes in the config.php are effective immediately like auto complete which I could test by accessing via dyndns. Unfortunately no effect


#4

That IP is missing from your array, it seems. Try adding it with

ncc config:system:set trusted_domains 4 --value=“192.168.20.91”


#5

You need to add the server’s IP in the trusted_domains array, not the client.


#6

Thank you both, will try again soon :slight_smile: