TrueNAS Core Nextcloud Encryption Issue

Good Day! I’ve been bashing my head at this problem for a few weeks now. I’ve got my TrueNAS Core computer up and running, but am struggling with getting Nextcloud to work 100%. After setting up encryption, I get a “Trouble Loading Page Error” (no, no the warning unsafe destination, please click a couple prompts to accept the risk and go anyways issue).

Right now I have a physical box running TrueNAS Core 13. All things good-to-go there. I can install Nextcloud just fine, and even get to the web gui and log in via ncadmin. My issue arises when I try to follow these steps ( How to turn TrueNAS into Cloud storage with Nextcloud - YouTube ) to make sure my connection is secure. I’m using a domain via my Asus router internal settings (instead of, but otherwise everything I do is the same as this video.

I thought I had the issue down last night. My domain had grabbed its own Let’s Encrypt certs, and then certbot was failing to establish certs to my domain because it already had some. So I changed that setting for encryption my domain to “None” and re-did the instructions. Certbot was able to publish certs to the domain, and I thought I finally did it. Except I still got the “Trouble loading this page” webpage error…again…

Any help/insight would be SUPER appreciated! Thanks in advance everyone!

For me it sounds, you are trying to set up an SSL encrypted connection. Just to make sure, there are other encryption functions, just to avoid the confusion (don’t get too excited either, the server-side file encryption is designed for external storages, not if it is on the same host).

For tutorials, it is better to have something written. For people wanting to help you, it is much faster to go through and just read the interesting part than to go through a video.

I’d look first, if the letsencrypt certificates were issued. Normally you find these in the letsencrypt configuration /etc/letsencryt, /etc/acme, or since it’s FreeBSD-based: /usr/local/etc/letsencrypt

If you have the keys, then it is probably a setting in the webserver, either you don’t have a virtual host for ssl, or the path to the key is not correct.

If you have done all these and you are not sure, it might be helpful to check the logfiles of the webserver: /var/log/nginx/*, if you start nginx, it will perhaps tell you if there is a problem with the format (forgotten ; in a file), a linked file or folder is missing etc.

I believe that the SSL is what I’m trying to do.

I am pretty sure the letsencrypt certs were issued, because it said that they were properly published during the setup. I’ll have to verify by digging into those files later tonight.

Umm, lost me a bit with that one haha.

So this is the error code that I’m very recently getting (replaced my actual domain name):

2023/05/03 14:07:56 [error] 21328#102070: connect() to failed(51: Network is unreachable) while requesting certificate status, responder:, peer:, certificate: “/usr/local/etc/letsencrypt/live/my.personal.domain/fullchain.pem”

This error is from when you renewed the certificate? Or always when restarting nginx?

I didn’t do anything for to activate that error code. It was just the most recent error in the logs.

not sure if these errors match the error in the logs. Therefore I’d check if you restart your webserver and try to access it, if you get the message again. Such loading troubles can also be linked to circular redirections etc.
What is strange, you normally get your certificates once and then you can just use them. They have to be renewed after some time.

Was able to find an install script and that set up everything perfectly. Appreciate all the help!!

If you have a link to it, it will probably appreciated by people running in the same issue.

Install Script Fix;

My journey to the fix:

1 Like