Troubleshooting Nextcloud Box setup

Hi. I got a Nextcloud Box because I love the concept, and the skill level required to install seemed to match my sub-script kiddie skill set and my high-level paranoia. Got the Raspberry Pi, got the box, put em together, patched it with an ethernet cable into the router, started it up, light went on ----

And can’t connect from my OSX computer. Or my Android phone. On any browser. (Yes, I tried all the usual suspects plus some weirdos). Haven’t tried any other device, because… I don’t have anything else. Every time I try nextcloud.local, from either device, on any browser, I get timed out.

Someone suggested turning on Bonjour on the OSX. Okay, in system preferences, went to sharing, turned on File Sharing, and rebooted. Still no soap. Should I have turned on Internet sharing? Something else? Do I need to change something on the router? Is it a problem I’m running DNSCrypt and also SurfEasy VPN? Does it matter that the Nextcloud Box is ethernet cabled in and my desktop and Android are wireless’d in? Does it matter that there is a wireless password?

Is there a dummy-level Nextcloud Box (with OSX [Yosemite] as main nearby computer) troubleshooting setup guide?

Does anything wrong in what I’m doing stand out to all you real hackers out there?

On a lot of networks the standard http://ubuntu-standard.local address will work fine, though not all (mine included).

Three immediate ways of finding the Box come to mind:

  • Run an IP scanner on your machine for your network range. It’ll be faster if you know the DHCP range set by the router
  • Open the router admin page, browse to the DHCP lease information and look for the Pi
  • Pop a HDMI cable and keyboard into the Pi, log in via commandline and run ifconfig -a - look for the IP that corresponds with your network setup.

I think I found the issue… Being a noob, I didn’t realize a microSD card was required. And it didn’t come with the Nextcloud box. No reply from WD support. Suggestions welcome.

I would log a ticket with WD as the item is not complete. If they’re ignoring you, you could always file a claim with your bank.

As for the issue at hand, find yourself a (minimum) 4GB SD card and follow the steps linked. It may look complicated but really isn’t hard once you’ve given it a go.

The micro SD card is easy to miss in the packaging. It would be easy to accidentally throw it out.

Perhaps. Still, I didn’t see it. Also, the Nextcloud box set up graphic doesn’t include anything on it referencing the microsd card. So, if I did throw it out, likely that was after looking at that graphic and following instructions - making the instructions non-noob proof.

@Puck Another gotcha you need to check is what version of RPi2 you have. Check the circuit board, if it’s says V1.2 it won’t work with the supplied SD Card image or the image linked above.

Raspberry Pi 2 Model B V1.1

Thank you for your help