Trouble with Letsencrypt

Trying to setup nextcloud at home. My internet and network is as follows.
ATT-Uverse modem (Arris NVG-599)—>TP Link AP (which handles DHCP for thehome network) ----> unmanaged linksys switch—>wired computers including the Raspberry pi.

I am following the instruction from a video by Techno Dad Life entitled Easiest Nextcloud Installation with Docker, to install nextcloud on my RPi running Open Media Vault. All has gone well, until I try to setup/get a certificate from letsencrypt in the nextcloudpi “control panel” I have checked by DDNSs in the panel, and they start without error. But, when trying letsencrypt, I get the following:

"[ letsencrypt ]

Invalid port in redirect target. Only ports 80 and 443 are
supported, not 8080

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you’re using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided."

I first turned off the firewall on the ATT Modem, to see if that resolved the issue, and it did not. I also tried port forwarding on the AP with the firewall turned off, with no luck. The ATT modem does not have a port forwarding option, but it does have NAT tables which I have tried, also with no luck.

Any help is greatly appreciated. I am not necessarily a newb at this stuff, but I am certainly no expert or professional, so thanks for bearing with me.

Kindly,
Michael

the errormessage tells you what exactly is wrong with your setup. standard letsencrypt needs ports 80 and 443 to be open.
of course there are ways to get different ports setup but it’s not really easy - plus afaik the automatic renewal wouldn’t work. but pls refer to the letsencrypt-side to see how you’d set that up.

1 Like

Thanks. I will try that.