Trouble authenticating from client

Support intro

I have two servers beneath my desk. One of them with owncloud instaled now I have started to run low on diskspace plus it is slow. I Copied all the files to my new machine and started upgrading to Nextcloud. Worked great expect a small hickup around version 15 or 16 which meant I had to start all over. Then I had some trouble getting SSL working. But now I that everything seemed to work and I tried to change the NAT in my router from the old to the new server i ran into the trouble with my windows desktop client not working. I know it worked sometime early in the upgrading process.
If I use the owncloud client I’m asked to enter my password but I get the response that my credentials are invalid.
I try with the Nextcloud client and I’m shown a webpage with a “connect” button and then I return to the client and login fails.

I’ve tried looking in the logfile but haven’t seen anything indicating what’s wrong.

Nextcloud version (
Operating system and version (Ubuntu 22.04):
Apache or nginx version (Apache 2.4.52):
PHP version (7.4):

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'maintenance' => false,
  'updatechecker' => false,
  'passwordsalt' => 'blurb,
  'secret' => 'blurb',
  'trusted_domains' => 
  array (
    0 => 'localhost',
    1 => 'blurb',
  'datadirectory' => '/var/www/blurb/public_html/data',
  'overwrite.cli.url' => 'http://localhost/owncloud',
  'dbtype' => 'sqlite3',
  'version' => '',
  'dbname' => 'owncloud',
  'dbhost' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'blurb',
  'dbpassword' => 'blurb',
  'instanceid' => 'blurb',
  'logtimezone' => 'UTC',
  'installed' => true,
  'csrf.disabled' => true,
  'log_rotate_size' => 1048576,
  'mail_smtpmode' => 'php',
  'theme' => '',
  'loglevel' => 2,
  'updater.secret' => 'blurb',

What’s your actual problem? You receive some sort of error presumably?

My trouble is not being able to logg in from the desktop client. Log in fails from the “Cirrus app” on my mobile as well. And I don’t have a clue whats causing it.

maybe it helps other and yourself if you describe very precise what happens

  • likely there is an error message…
  • clients logs things as well (refer to the manual)…
  • can you login via Web?

performing this actions must result in some logs in your firewall, web server (and reverse proxy if used). depending on the outcome you can focus on the faulty components and analyze it further…

Ownclod client logfile shows this:
22-12-07 09:57:15:923 [ info sync.httplogger ]: “388e7a43-7cbb-452c-9fe1-08c18e5a255a: Response: PROPFIND 401 (Error: Host requires authentication,120ms) https://blurb.blu/remote.php/webdav/ Header: { Date: Wed, 07 Dec 2022 08:57:15 GMT, Server: Apache/2.4.52 (Ubuntu), Expires: Thu, 19 Nov 1981 08:52:00 GMT, Cache-Control: no-store, no-cache, must-revalidate, Pragma: no-cache, Referrer-Policy: no-referrer, X-Content-Type-Options: nosniff, X-Frame-Options: SAMEORIGIN, X-Permitted-Cross-Domain-Policies: none, X-Robots-Tag: none, X-XSS-Protection: 1; mode=block, Content-Security-Policy: default-src ‘none’;, WWW-Authenticate: Basic realm="Nextcloud", charset="UTF-8", Keep-Alive: timeout=5, max=100, Connection: Keep-Alive, Transfer-Encoding: chunked, Content-Type: application/xml; charset=utf-8, } Data: [<?xml version=\"1.0\" encoding=\"utf-8\"?>\n<d:error xmlns:d="DAV:" xmlns:s="\”>\n <s:exception>Sabre\DAV\Exception\NotAuthenticated</s:exception>\n <s:message>No ‘Authorization: Basic’ header found. Either the client didn’t send one, or the server is misconfigured, No ‘Authorization: Bearer’ header found. Either the client didn’t send one, or the server is mis-configured</s:message>\n</d:error>\n]

Forgot that question, yes I have no trouble logging in via the web. It is just the clients that don’t work.