Синхронизация документов и таблиц


Nextcloud version (eg, 20.0.5): 25.0.1
Operating system and version (eg, Ubuntu 20.04): Debian GNU/Linux 11
nginx version (eg, Apache 2.4.25): 1.18.0
PHP version (eg, 7.4): 8.0.25
ONLYOFFICE version: 7.6.8
Nextcloud client version: 3.6.4

The issue you are facing: Создаём файл (либо доукмент, либо таблицу. разницы нет) в Nextcloud. Вносим изменения в файле, открытом локально, сохраняем, закрываем. Проверяем в веб-интерфейсе. Изменения применились. Открываем этот же документ в веб-интерфейсе, вносим изменения, сохраняем. Обновляем директорию локально, открываем этот файл локально - изменений нет.

Is this the first time you’ve seen this error? (Y/N):N

Steps to replicate it:



  1. Создали файл (документ или таблицу)
  2. Расшарили для других пользователей
  3. В клиенте внесли изменения, сохранили
  4. Проверили в веб-интерфейсе. Изменения применились.
  5. Открыли этот же файл в веб-интерфейсе.
  6. Отредкатировали.
  7. Сохранили.
  8. Открыли этот же файл в веб-интерфейсею
  9. Внесли изменения.
  10. Сохранили.
  11. Обновлили директорию с файлом в клиенте.
  12. Открыли этот файл в клиенте.
  13. Изменения не применились.



  1. Создали файл (документ или таблицу)
  2. Расшарили для других пользователей
  3. В веб-интерфейсе внесли изменения
  4. Проверили в веб-интерфейсе под другим пользователем. Изменения не применились. Даже если подождать чуть чуть подольше. Не зависит от того, что на шаге 3 сохраняли документ или нет. Не зависит от того, какой режим редактирования был выбран.

The output of your Nextcloud log in Admin > Logging:


no log

The output of config.php file:

Спойлер <?php $CONFIG = array ( 'instanceid' => '', 'passwordsalt' => '', 'secret' => '', 'trusted_domains' => array ( 0 => 'foo.ru', ), 'datadirectory' => '/var/data/nextcloud_data', 'dbtype' => 'mysql', 'version' => '', 'overwrite.cli.url' => 'https://foo.ru', 'dbname' => 'clouddb', 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'oc_', 'mysql.utf8mb4' => true, 'dbuser' => '', 'dbpassword' => '', 'default_language' => 'ru', 'default_phone_region' => 'RU', 'installed' => true, 'memcache.local' => '\\OC\\Memcache\\APCu', 'memcache.distributed' => '\\OC\\Memcache\\Memcached', 'memcached_servers' => array ( 0 => array ( 0 => '', 1 => 11211, ), ), 'mail_from_address' => 'cloud', 'mail_smtpmode' => 'smtp', 'mail_sendmailmode' => 'smtp', 'mail_domain' => 'foo.ru', 'mail_smtpauth' => 1, 'mail_smtpauthtype' => 'LOGIN', 'mail_smtpsecure' => 'ssl', 'mail_smtphost' => 'smtp.yandex.ru', 'mail_smtpport' => '465', 'mail_smtpname' => 'foo@foo.ru', 'mail_smtppassword' => '', 'twofactor_enforced' => 'true', 'twofactor_enforced_groups' => array ( 0 => 'admin', ), 'twofactor_enforced_excluded_groups' => array ( ), 'maintenance' => false, 'theme' => '', 'loglevel' => 2, 'updater.release.channel' => 'stable', );

I’m not very clear I follow your explanation right regarding “refresh local directory”… If you just refresh it locally within your file manager it’s not enough. desktop client sync is not instant by default… (as long you didn’t deploy notify_push)

Please wait little longer until you check if you server-side changes arrive locally… (maybe restart the client to force a sync cycle). Maybe test the same with regular text file to know if the issue is generic or related to onlyoffice

Unfortunately, this problem is floating. It is not always possible to replicate it.

I added an update to the topic. There is second case for replicate the issue with syncing files there.

The issue is still not solved.

you are the only one who can analyze the issue. Without more testing, logs etc other simply guess… I suggest you simplify the test case going away from office docs to the simple text files. check how long it take until changes replicate from the server to the client, review the logs both server and client if you see any error, look for the updated file - is there some activity related to the file? add such details to the topic so others can support you…