The server encountered an internal error and was unable to complete your request - NO LOG

Hya,

by starting the server, i get the followinf message:

The server encountered an internal error and was unable to complete your request

I tried to see what log shows, but log is empty.

Any clue in how to figure out what can be wrong?

Thx in advance.

Which log are you looking at?

A 500 error (this error) will be logged in 2-3 places:

  • your web server access log (as a 500 status transaction)
  • your web server error log (with a few additional details)
  • the Nextcloud Server log (if the error is coming from Nextcloud itself; if so, this will have the most information)

Thx for answering. By web server error.log i found this:

[Sun Feb 11 11:44:08.826844 2024] [proxy_fcgi:error] [pid 3248] [client 192.168.28.182:32772] AH01071: Got error 'PHP message: PHP Fatal error:  Uncaught Doctrine\\
DBAL\\Exception: Failed to connect to the database: An exception occurred in the driver: SQLSTATE[HY000] [2002] No such file or directory in /var/www/nextcloud/lib/
private/DB/Connection.php:139\nStack trace:\n#0 /var/www/nextcloud/3rdparty/doctrine/dbal/src/Connection.php(1654): OC\\DB\\Connection->connect()\n#1 /var/www/nextc
loud/3rdparty/doctrine/dbal/src/Connection.php(865): Doctrine\\DBAL\\Connection->getWrappedConnection()\n#2 /var/www/nextcloud/3rdparty/doctrine/dbal/src/Query/Expr
ession/ExpressionBuilder.php(321): Doctrine\\DBAL\\Connection->quote()\n#3 /var/www/nextcloud/lib/private/DB/QueryBuilder/ExpressionBuilder/ExpressionBuilder.php(42
2): Doctrine\\DBAL\\Query\\Expression\\ExpressionBuilder->literal()\n#4 /var/www/nextcloud/lib/private/Lock/DBLockingProvider.php(252): OC\\DB\\QueryBuilder\\Expres
sionBuilder\\ExpressionBuilder->literal()\n#5 [internal function]: OC\\Lock\\DBLockingProvider->releaseAll()\n#6 {main}\n  thrown in /var/www/nextcloud/lib/private/
DB/Co...

possible cause? was working without problem yesterday.

Your database server is offline.

found out that php-msqli was missing after php update :frowning:
after installing php8.1-msqli problem was solved.

thx for the support.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.